Sarka-SPIP compatible SPIP 3 !

dimanche 30 septembre 2012
par  _Equipe_
popularité : 13%

Début Juin nous vous avions annoncé une version imminente de Sarka-SPIP compatible avec SPIP 3, la nouvelle version majeure de notre CMS préféré. Finalement, c’est en Octobre que celle-ci sort enfin le bout de son nez... no comment.

Mais, cette nouvelle n’est pas la seule :

  • Sarka-SPIP 4.0 est en préparation et marquera une rupture très importante avec tout ce que nous avons connu depuis la version 1.9 du squelette,
  • Sarka-SPIP 3.0 est abandonnée au profit de la branche 3.1 plus complète et suffisamment stable aujourd’hui.

Une branche 3.2 compatible SPIP 3.0

Les mêmes fonctionnalités mais pas les mêmes plugins

Le petit nom de cette branche est Sarka-SPIP 3.2 pour bien préciser qu’il ne s’agit pas d’une version majeure introduisant des ruptures de compatibilité avec les versions 3.0.x ou 3.1.x déjà installées. Vous pourrez donc utiliser toutes vos personnalisations avec cette nouvelle branche 3.2 sans rien changer. En outre, cette branche propose exactement les même fonctions que la branche 3.1.

Coté plugins, CFG, n’est plus utile avec Sarka-SPIP 3.2. La configuration du squelette s’appuie sur l’API fournit nativement par SPIP 3. En outre, tous les plugins de box - fancybox, smoothgallery, nyroceros - ne sont plus compatibles avec le squelette car ils ont été remplacés par le plugin Mediabox installé avec SPIP 3.

En ce qui concerne les autres plugins pouvant être utilisés avec Sarka-SPIP : les dernières mises à jour de Socialtags, Crayons, Boutons Texte, Splickrbox, Ancres Douces fonctionnent parfaitement. Pour les autres rien n’est garanti mais nous les testerons dans les prochaines semaines. Votre support est le bienvenu aussi.

Comment installer et tester cette nouvelle version ?

La première étape consiste à se familiariser avec SPIP 3.0 ! Les sites de tests de SPIP - http://demo.spip.net/ et http://grml.eu/ - sont fait pour ça et nous remettrons rapidement en route le site de démo de Sarka-SPIP.

Ensuite, ne vous lancez pas sur une migration de votre site en production mais testez la démarche d’abord en local à partir d’une sauvegarde complète de votre site.

Une fois satisfait du résultat refaite une sauvegarde complète de votre site en suivant les explications données dans ce post : Mise à jour vers 3.2.

N’oubliez pas non plus de partager vos expériences sur le forum ouvert à cet effet : Sarka-SPIP 3.2 compatible SPIP 3.

La fin de la branche 3.0 au profit de la 3.1 pour SPIP 2

La version 3.0.8 est la dernière version de la branche 3.0 qui ne subira donc plus aucune modification à partir d’aujourd’hui. Seule la branche 3.1 continuera à être supportée sous SPIP 2. N’hésitez donc pas à passer en 3.1 si vous comptez rester encore en SPIP 2 : ce sera totalement transparent et vous pourrez utiliser les nouveaux forums phpBB-like.

L’avenir s’écrira en Z

Le futur de Sarka-SPIP est en route : ce sera la branche 4.0 basée sur le concept Z et le framework Bootstrap. Le développement est en cours et nous vous tiendrons au courant dès qu’une première version beta sera disponible : mais attendez-vous à un vrai choc !

Bon tests et rendez-vous sur le forum !

L’équipe Sarka-SPIP