Insérer une vidéo dans SPIP

samedi 27 janvier 2007
par  Fredo
popularité : 6%

Insérer une vidéo peut être intéressant pour illustrer un article afin de le rendre plus explicite ...

Il est possible, sous SPIP d’insérer une vidéo et voici la marche à suivre ; a l’aide du lien proposé :

- Télécharger RIVA FLV Encoder
Cet utilitaire permet d’encoder les formats .avi, .mpeg, quicktime, .wmv au format .FLV

- Télécharger Flash Vidéo SPIP (À renommer en flvplayer.swf)
Cela va être le player de la vidéo !

Voilà, à présent vous avez les outils en main !

1/ Encodez à l’aide de RIVA FLV votre vidéo au format .FLV

2/ Placez votre fichier .FLV ainsi crée et flvplayer.swf dans le même dossier ftp de votre site.


Insérez le code suivant dans votre article pour insérer votre vidéo
en remplaçant < par * et > par ** (justement, afin que SPIP n’interprête pas le code suivant pour cet article !

*object type="application/x-shockwave-flash" width="320" height="260" wmode="transparent"
data="http://votresite/flvplayer.swf?file=votresite/votrevideo.flv"** *param name="movie"
value="http://votresite/flvplayer.swf?file=votresite/votrevideo.flv"/** *param name="wmode" value="transparent" /** */object**

Remplacez "votresite" par l’adresse de vos vidéos ...

Voilà, c’est prêt !

- Vous pouvez modifier la hauteur et largeur de votre vidéo en modifiant les valeurs de width et height.

D’un point de vue personnel :

Le plus difficile est à mon avis d’obtenir ce fichier .flv car selon la qualité et le type de format du fichier original, cela fonctionne plus ou moins bien.

Insérer le code dans l’article lui même pour interpréter la vidéo me semble plus facile à comprendre que de modifier les codes sources de SPIP pour automatiser la procédure ...

Amusez vous bien ! et n’oubliez pas de faire attention particulièrement aux droits d’auteurs des vidéos que vous êtes amenés à diffuser !

Un exemple du résultat ici : Démo


Net dévelopeur

Commentaires  forum ferme

Logo de _Philippe_
Insérer une vidéo dans SPIP
mercredi 14 mai 2008 à 16h38 - par  _Philippe_

Bonjour à tous,

Je me permets de poster dans ce thread pour signaler l’existence d’un plugin que j’utilise avec succès : le Lecteur Multimédia.

Il faut encoder la vidéo en flash et j’utilise personnellement pour cela : Super © de eRightSoft (gratuit).

Après avoir chargé la vidéo en tant que document joint, l’intégration dans un article est la suivante :

<docxx|player|right>
xx étant le n° du document
right si on désire un affichage à droite du corps de l'article (left|center|right)

Possibilité d’affichage en plein écran.

Si cela peut aider …

Lien ci-dessous pour voir une vidéo qui sera bientôt remplacée par une autre de meilleure qualité ([*réalisée en 2007 avec un téléphone portable !! taille : 671 Ko*])

Philippe

Logo de _Philippe_
mardi 19 août 2008 à 15h48 - par  fred44

Tu peux télécharger FileZilla qui te permettra de te connecter directement en FTP sur ton site. De cette façon, tu pourras "balancer" sur ton serveur de très gros fichiers vidéo.
En utilisant un player Flash et un fichier flv, la taille de ton fichier ne compte pas, ce qui est important c’est le débit !

J’utilise ffmpeg pour régler la compression et le débit. si tu veux en savoir plus, j’ai un petit topo sur : http://www.adventure-rally.com/spip.php?article178
voilà ;)
bon courage à toi...

Logo de fred44
mardi 22 juillet 2008 à 23h01 - par  _Eric_

Salut Pathéo,

Moi je trouve pas qu’ils soient mal placés mais c’est une affaire de goût.
Sinon, j’avais regardé comment faire pour les déplacer mais je n’avais pas trouvé. Il est peut-être possible de le faire avec la config cfg du plugin.

Voila

Logo de _Eric_
mardi 22 juillet 2008 à 12h30 - par  patheo

Salut SarkASmeL ! merci pour le conseil mais mon problème avec ce plugin est que les bottons sont mal disposés (dans le texte pour certains articles). Comment personnaliser la position des boutons (les aligner par exemple avec les boutons de imprimer et pdf) ? Merci

Logo de patheo
lundi 21 juillet 2008 à 23h19 - par  _Eric_

Salut Pathéo,

Utilise le plugin BoutonsTexte.

A+

Logo de _Eric_
lundi 21 juillet 2008 à 21h28 - par  patheo

bonsoir je veux donner la possibilité à mes visiteurs de faire d’agrandir ou de diminuer le texte des articles. comment faire ?

Logo de patheo
dimanche 20 juillet 2008 à 17h00 - par  Fredo

Bonjour Jeaneric,

En consultant l’article 158 de ton site, je constate que tout fonctionne correctement à présent. :)

Logo de Fredo
dimanche 20 juillet 2008 à 08h20 - par  jeaneric

Salut philippeguerindon1 !
J’ai un soucis avec le plugin que tu mentionnes : tout va bien dans la partie privee mais dans la partie publique (qd on visualise l’article) la fenetre du player n’apparait pas.

J’ai utilise Firebug sous Firefox et voila :

<div class="texte">
Il y a peut-etre un bug au niveau de l'implemention des filtres
<doc561|player|center _moz-userdefined=""> </doc561|player|center>
<div class="clearer"/>
<br/>
<a class="repondre" href="http://amisaca92.free.fr/spip.php?page=forum&id_article=158">Répondre à cet article</a>
<br/>
</div>

Je me demande si le modèle de Lecteur Multimédia n’interagit pas avec celui de SARKA ?

Une idée ?

JE

Logo de jeaneric
samedi 19 juillet 2008 à 22h14 - par  jeaneric

Tres interessant !
J’ai telecharge le plugin, puis encode mes avi en flash (verifie avec VLC), puis charge le tout sur mon site web via ftp dans tmp/upload.
Dans un article, j’ai importe mes avi comme doucment de l’article (soit lors de la redaction, soit une fois l’enregistrement fait). J’ai mis le code <docxx|player|center> avec xx le numero de mon document flv.
Dans la zone privee, ok, j’ai la fenetre du player pret a l’emploi, mais dans l’interface public du site, mes flv apparaissent comme documents joints mais il n’y a pas de fenetre du player !!...

de l’aide ?

Logo de jeaneric
jeudi 22 mai 2008 à 09h05 - par  jacques

Une question sur l’agenda :
Sous sarka 2.0.2 , spip 192d , est-il possible ,une fois l’évenement passé, de faire en sorte qu’il n’apparaisse plus dans le mini-agenda public et dans l’agenda des évenements ? Libérant ainsi une place "évenements" du mini-agenda
pour permettre d’inclure un autre ,ayant fixé le nombre d’"évenements" à 7, si ils sont passés, inutile de les laisser afficher par conséquent.
Si oui , comment faire ?

Logo de jacques
mardi 20 mai 2008 à 20h43 - par  jacques

En fait l’agenda public affiche seulement
5 évenements donc lorsque j’en avais 7 dont 2 sur la même journée, forcement , il
ne s’affichait pas puisque > à 5
Maintenant j’ai trouvé suffit d’augmenter le nombre d’évenements.
Pour les catégories , c’est ok j’ai vu l’article squelette_agenda et ses mots clefs donc en ordre.
Cependant,je ne sais toujours pas où aller pour supprimer "aucun filtre" et "sans catégories".

Logo de jacques
lundi 19 mai 2008 à 22h08 - par  _Eric_

Jacques,

Je comprends pas ta question car c’est effectivement le cas dans le mini-agenda :

- dans le calendrier, en bulle d’info du jour concernés tu vois le premier événement et un commentaire donnant le nombre d’événements du jour. En fait, les bulles par défaut ne pouvant contenir de retour à la ligne, la taille serait trop importante sinon.
- dans le résumé, tous les événements du mois sont affichés (avec un max modifiable)

A+

Logo de _Eric_
lundi 19 mai 2008 à 22h02 - par  _Eric_

Re,

L’agenda par défaut non, mais il sera possible d’utiliser le plugin agenda qui répond à ce besoin.

A+

Logo de _Eric_
lundi 19 mai 2008 à 22h01 - par  _Eric_

Jacques,

Non les événements doivent être uniquement dans le secteur associé au mot-clé agenda. Ensuite tu peux catégoriser tous tes événements par des mots-clés appartenant au groupe squelette_agenda. Quand tu affiches la page agenda, tu as a droite un bloc de catégories permettant de filtrer les événements.

Donc tu n’as pas besoin de plusieurs rubriques car tu as les catégories.

Lis ou relis les articles à ce sujet...

A+

Logo de _Eric_
lundi 19 mai 2008 à 17h48 - par  jacques

A cet instant , dans l’état actuel de Sarka , comment faire pour que 2
évenements situés sur la même date s’affichent dans l’agenda "public"
p.ex.cours le 30/5/08 de ...à 18h30
et stage le 30/5/08 de ....à 19h30
Les endroits où se déroulent les activités sont différents,mais l’agenda
"public" ne m’affiche que le premier sur la grille horaire

Logo de jacques
lundi 19 mai 2008 à 16h35 - par  jacques

Bon pour l’agenda et rangement par catégories ,j’ai trouvé ,curieux de voir
si dans la version qui viendra,on aura
un agenda pouvant gérer un étalement
des dates

Logo de jacques
lundi 19 mai 2008 à 16h12 - par  jacques

Merci de l’explication
Juste encore une question:Etant donné
que des stages se déroulent à certaines dates
Je souhaiterais que les articles qui se situent dans la rubrique stage apparaissent dans l’agenda.
J’ai bien attribué le mot clef agenda
à ma rubrique agenda de même que à ma sous
rubrique stage (catégories ?) cependant les articles n’apparaissent pas dans l’album , on parle
de pouvoir créer ou trier par catégories,mais j’avoue ne pas en avoir saisit le principe même si il s’avère simple car ma catégorie stages reste vide donc j’ai dû louper quelque chose .

Logo de jacques
dimanche 18 mai 2008 à 00h58 - par  Fredo

Bonsoir Jacques,

Rectifiez moi si je me trompe mais je crois qu’il faut bien distinguer 2 situations :

- Le répertoire tmp/upload est utilisé pour déposer des fichiers volumineux, à l’aide d’un client ftp, pour ensuite sélectionner ces éléments lors de la création d’un article, en dépliant le cartouche de gauche intitulé "ajouter un document".

- Ensuite, il est tout a fait normal que SPIP retravaille les photos du répertoire IMG. Ce procédé de cache permet d’éviter de recalculer inutilement une page lorsqu’elle est consultée une deuxième fois. Le seul réglage que je vois se situe au niveau de l’interface privé dans le menu configuration/Fonctions avancées.

Logo de Fredo
samedi 17 mai 2008 à 23h41 - par  jacques

Simplement parce que j’ai mal interprété ce qui m’a été conseillé de transférer tous mes fichiers dans le dossier squelettes si modifié or mes photos sont toujours retravaillé pour atteindre le moins de poids possible.Mais même si je les déplace ailleurs ,comment limiter le fait que spip les recopie en fichiers auton ou arton ou artoff dans IMG et que cela me prend de la place disque inutile car on les retrouve aussi dans le tmps/upload qui est devrait être normalement le bon répertoire si j’ai bien compris. Je souhaiterais que une fois mis dans le bon répertoires , il ne les recopies plus ailleurs donc comment faire ?

Logo de jacques
samedi 17 mai 2008 à 18h59 - par  _Xavier_


je transfères les images dans le repertoire images du squelettes

hein ?

Quel est l’intérêt ? je ne vois pas pourquoi tu passes par le répertoire images du squelettes. Celui ci est "réservé" aux images utilisées par le squelette (comme sont nom l’indique) et non aux images servant au contenu du site.

Les images insérés par la commande "AJOUTER UNE IMAGE" dans l’édition d’un article se copient dans le répertoire IMG de spip

++
SarkARchimed

Logo de _Xavier_
vendredi 16 mai 2008 à 21h56 - par  jacques

www.seishokan.be.ma ,site pas encore complet,mais la rubrique vidéo fonctionne
et le problème des vidéos est apparemment
résolu.
Toutefois le problèmes des photos images
que spip gère n’a toujours pas de solution
càd je transfères les images dans le repertoire images du squelettes et j’en trouve dans tmp et dans img de spip ,cela prend bcp de place,y a t il moyen de limiter cela en obligeant spip à ne pas creer des copies partout des images transférées ?

Logo de jacques
vendredi 16 mai 2008 à 20h44 - par  jacques

Merci cela me permettra d’avoir une vidéo sur un server distant comme VEOH , je viens de reduire le 130MO avec pocketdivxencoder à 7.5Mo en avi , convertit ensuite en flv à 11mµMo avec free video to flash de dvdvideosoft,j’ai
transferer le player swf et le flv fournit avec ce dvdvideosoft et bonheur en mettant le code dans l’article , spip a bouffé le player et le flv donc encore une truc de plus pour mettre une video dans spip
toutefois mon problème n’est qu’à moitié résolu car je ne sais toujours pas commet faire pour mettre 2 ou 3 videos de la meme façon vu que le fichier flv et son player est dans la racine même de spip donc si > 1 vidéo comment va réagir spip (vidéo ou pas ?) comment par conséquent les mettre et le faire comprendre à spip qu’il doit les chercher là bas en utilisant ce player et des articles différents ?

Logo de jacques
vendredi 16 mai 2008 à 20h19 - par  _Philippe_

Il est possible de télécharger avec un client FTP le gros fichier vidéo et ensuite de le placer dans le porte folio de l’article à l’aide du plugin Importer massivement des documents distants . Il suffira de recopier le lien vers le chemin complet du fichier vidéo.

En l’occurrence, il n’y aurait qu’un document à importer.

N.B.Le plugin ne rattache que le (ou les) lien HTTP à l’article, il ne fait aucun upload.

Logo de _Philippe_
vendredi 16 mai 2008 à 14h56 - par  jacques

C’est très bien,mais lorsque les vidéos
ont , sous format swf ou flv, 3,5 à 11Mo,
c’est plutôt difficile l’usage de l’upload
car spip ne permet l’upload de plus de
2Mo en doc.joint et sur veoh , le fichier
Mpg fait 130Mo c’est lourd au loading.
J’avais trouvé en freeware dvdvideosoft.com qui permet de convertir
plusieurs format de fichier avec le player flv + html adéquat cependant je ne sais pas où mettre fichier video flw+player ou le fichier swf
comment faire ? Une page Html pure et dure n’est pas un article spip alors que dans spip on peut inclure du html , qu’en fait il ? Que de questions pour des vidéos....

Logo de jacques
Insérer une vidéo dans SPIP
mercredi 7 mai 2008 à 11h46 - par  jacques

1°) Est-ce que l’on peut mettre une vidéo dans un article qui aurait comme mot clef edito ?
2°) Comment mettre justement cette vidéo
en première page ,certains sites spip écrivent d’aller sur dailymotion,
d’autres de ne faire qu’une pièce jointe
à un article et si je désires mettre cela dans une rubrique c.fr p.ex galerie , que faire ?
3°) Faut il thickbox en plus de splickbox ?

Logo de jacques
mercredi 7 mai 2008 à 23h06 - par  _Eric_

Jacques,

Je trouve que la technique que nous avons utilisé pour le tuto de présentation est pas mal. Tu déposes ta vidéo sur veoh et tu inclus uniquement dans ton article le code suivant :

<center><embed src="http://www.veoh.com/videodetails2.swf?permalinkId=v15304236bJhxbY7&id=6331979&player=videodetailsembedded&videoAutoPlay=0" allowFullScreen="true" width="400" height="326" bgcolor="#000000" type="application/x-shockwave-flash" pluginspage="http://www.macromedia.com/go/getflashplayer"></embed></center>

Va sur le site et laisse toi guider c’est très simple. Cela aussi évitera d’écrouler les perfos de ton site perso.

A+

Logo de _Eric_
mercredi 7 mai 2008 à 20h03 - par  jacques

Actuellement , je me tâtes euh non pas comme vous le pensez ;-) je réfléchis càd
le poids pour l’hébergeur un fichier mov par rapport à un swf et
si je convertis,éventuellement, ces vidéos en fichier swf ,pour les mettre
dans sarka spip,en est-il de même au niveau d’un article ?
Et si je désire garder le contexte sarka c-à-d la mise en page , je bidouille dans les css ?à quel niveau ? c.fr votre video de présentation de sarka

Logo de jacques
mercredi 7 mai 2008 à 17h16 - par  jacques

Mais pour le plugin xspf ne faut-il pas
un spip 1.9.3 ? Or je tourne sous spip 1.9.2d , le 1.9.3 n’étant pas prêt de sortir demain , je pense !

Logo de jacques
mercredi 7 mai 2008 à 16h43 - par  jacques

de la façon suivante : ??? (blanc !)Sinon

euh ! quelle façon suivante ?
il y aurait pas comme un oubli,là, peut-être ;-)

Logo de jacques
mercredi 7 mai 2008 à 13h31 - par  _Eric_

Jacques,

Tu peux insérer une vidéo dans n’importe lequel de tes articles et l’édito n’est rien d’autre qu’un article.

Ensuite, tout dépend si tu héberges la vidéo sur ton site ou si tu la "stream" à partir d’un site comme dailymotion ou autre. Dans ce cas, nul besoin de lecteur tu peux simplement insérer un object dans le corps de ton article de la façon suivante :

<object width="425" height="355"><param name="movie" value="http://www.youtube.com/v/Sub_g4efSoc&rel=1"></param><param name="wmode" value="transparent"></param><embed src="http://www.youtube.com/v/Sub_g4efSoc&rel=1" type="application/x-shockwave-flash" wmode="transparent" width="425" height="355"></embed></object>

Sinon, après les lecteurs multimédia comme le plugin xspf font aussi l’affaire. A toi de voir...

A+

Logo de xadim
Insérer une vidéo dans SPIP
mercredi 23 avril 2008 à 11h27 - par  xadim

Bonjour,
Je viens d’utiliser votre script pour les vidéos flv. Il marche à merveille seulement j’essaie de désactiver l’option autostart mais j’y arrive pas. Quelqu’un a une idée sur ça ?
Merci à tous.

Logo de jpv56
Insérer une vidéo dans SPIP
mercredi 20 février 2008 à 17h32 - par  jpv56

Bonjour,
Depuis plusieurs mois je cherche mais je n’arrive pas à insérer de vidéo en flash dans mes pages SPIP et je désespère. J’ai suivi le tuto (insertion du code dans l’article) mais là encore j’échoue lamentablement...
En fait je ne pige pas trop au niveau du chemin vers ma vidéo : dois-je indiquer le chemin (relatif, absolu ?) où sont stockés le player et la vidéo en LOCAL ou bien sur le SERVEUR ?...
Par ailleurs mon player (flvplayer) ne pèse que 3 malheureux KO. Est-ce normal ?
Merci d’avance pour votre aide.

PS : pour info j’ai placé le player et la vidéo dans le dossier IMG en local. Est-ce un problème ?

Logo de jpv56
vendredi 22 février 2008 à 10h32 - par  jpv56

Bonjour Fredo,
Ca y est j’y suis arrivé !...
Je te remercie infiniment de m’avoir aidé.
++ et bonne continuation :)

- jpv56 -

Logo de jpv56
vendredi 22 février 2008 à 00h48 - par  Fredo

hum... les astérisques de l’exemple sont là uniquement pour que SPIP n’interprète pas le code !

Remplacer le * par < et ** par >

Placez votre player et la vidéo sur votre serveur.

Logo de Fredo
jeudi 21 février 2008 à 13h54 - par  jpv56

Bonjour,
Je suis confus j’y parviens toujours pas.
Pour faciliter les choses je me permets de donner les éléments nécessaires à l’insertion du bon chemin dans le code.

En local le player et la vidéo sont dans le dossier IMG, à savoir ici :
C :\AVOCETTE SITE WEB\www\IMG

Dans l’article (insertion du code) voici ce que j’obtiens :

*object type="application/x-shockwave-flash" width="320" height="260" wmode="transparent" data="http://www.ecoleavocette.fr/www/img/flvplayer.swf ?file=http://www.ecoleavocette.fr/www/img/Crysis.flv"** *param name="movie" value="http://www.ecoleavocette.fr/www/img/flvplayer.swf ?file=http://www.ecoleavocette.fr/www/img/Crysis.flv" /** *param name="wmode" value="transparent" /** */object**

Si vous pouviez m’indiquer mon ou mes erreurs et me donner la solution...
Merci d’avance !

- Jpv56 -

Logo de jpv56
mercredi 20 février 2008 à 22h19 - par  Fredo

Bonjour jpv56,

Le player et la vidéo en .flv doivent se trouver dans un répertoire (de votre choix) dans le serveur.
Et il faut indiquer le chemin complet.

Dans l’extrait de code suivant par exemple, on indique ou se trouve le player ( et c’est normal qu’il soit tout petit) et juste après le ? se trouve l’adresse du fichier à traiter.

data="http://cecm82.free.fr/boumbo/flvplayer.swf?file=http://cecm82.free.fr/boumbo/boumbo.flv">

Bon, c’est vrai que l’article n’est peut-être pas super bien rédigé et mérite peut être d’être amélioré pour en faciliter la compréhension.

Voilà, essayez à nouveau et tenez nous au courant pour savoir si cela fonctionne.

Logo de brunobambois
Insérer une vidéo dans SPIP
dimanche 9 décembre 2007 à 22h21 - par  brunobambois

Très bien, tout baigne, MAIS :

L’image initiale de la video, avant de cliquer, est noire ! Comment avoir une belle image au départ ?

Merci pour votre aide

Logo de brunobambois
mercredi 20 février 2008 à 22h49 - par  Fredo

Désolé pour le retard de la réponse.

Le mieux est d’utiliser le plugin "lecteur multimédia" qui fait ça très bien.

- Allez sur la Zone spip pour le télécharger et l’installer.

- Dans l’espace privé, dans le menu configuration>gestion des plugins, activez le !(cocher la case et valider)

- Attachez votre fichier Multimédia (flv, mp3, etc...) en pièce jointe dans un article et utilisez la balise : docXX|player entre < >

Nb : si le fichier multimédia joint est trop gros, il vaut mieux le placer directement par ftp sur votre serveur sous le répertoire /temp/upload pour ensuite aller chercher le média dans le cartouche joint à l’article.

Logo de brunobambois
Insérer une vidéo dans SPIP
jeudi 30 août 2007 à 19h43 - par  brunobambois

Tout va bien, les vidéos tournent à merveille, mais .... l’image au départ est noire. Comment faire pour avoir une image de notre choix, avant de cliquer pour faire démarrer la vidéo ?

Merci pour votre aide.

Logo de brunobambois
Insérer une vidéo dans SPIP
samedi 25 août 2007 à 13h29 - par  brunobambois

Oui, OK, mais Riva n’est pas compatible Mac !!

Quel encodeur prendre dans ce cas ?

Logo de brunobambois
samedi 25 août 2007 à 18h39 - par  brunobambois

Finalement tout baigne : ffmpegx ne voulait pas encoder à partir de .mov, mais à partir de . avi pas de pb. Ma video sur le site fonctionne du coup !

Merci encore

Logo de brunobambois
samedi 25 août 2007 à 17h34 - par  brunobambois

Merci pour la réponse. J’ai déjà essayé ffmpegx, mais j’y ai un pb : le fichier créé est vide ....
Quand à mettre un plugin, mon site est sous Spip 1.8.2e, et passer sous spip 1.9. me fait un peu peur ...

Logo de brunobambois
samedi 25 août 2007 à 15h52 - par  Fredo

D’autres encodeurs existent pour créer des fichiers .FLV . Pour la compatibité MAC, regardez ce lien. Essayez donc d’utiliser le plugin Multimédia pour SPIP proposé par Bo0z , ce serait même mieux et plus facile à mettre en oeuvre !

Logo de don.kamyo974
Insérer une vidéo dans SPIP
jeudi 14 juin 2007 à 02h47 - par  don.kamyo974

Je précise que je travail en local avec spip, c’est peut-etre le soucis ?
Merci A+

Logo de don.kamyo974
Insérer une vidéo dans SPIP
jeudi 14 juin 2007 à 02h37 - par  don.kamyo974

Salut,
bien mon pb c’est que je vois bien ma video dans mon espace privé en consultant mon article. Par contre lorsque je visite mon site ça me retourne une page d’erreur qui commence par : * Erreur(s) dans le squelette
o Erreur sur le site, )]/[(#ENVvideo)]" height="260" width="320">

Tu peux m’éclairer si ça te parle.

Merci

Logo de Christian
Insérer une vidéo dans SPIP
dimanche 20 mai 2007 à 19h33 - par  Christian

Bonjour,

j’ai essayé de réaliser cette méthode, mais rien y fait.
mon fichier video.flv fait 25 mega, il se lit bien en local avec Riva videoplayer, mais je ne vois rien sur mon site.

j’ai ôté les espaces devant les " ?" mais je reste toujours devant un rectangle blanc.
je travaille avec SPIP 1.9.2 [8782] et Sarka-SPIP 1.9.1 [163], ai-je oublié qqc à écrire ou à modifier dans les squelettes.

Cordialement

Christian

Logo de Christian
dimanche 20 mai 2007 à 23h18 - par  Fredo

Bonsoir,

La taille de la vidéo n’est pas le probleme. Il ne faut pas oublier de rajouter le lecteur flv (flvplayer.swf ) à l’interieur du répertoire ou se trouve votre fichier video.flv.

Faire aussi attention aux minuscules/majuscules pour le nom des fichiers.

Cordialement,
Frédo.

Logo de nova06
Insérer une vidéo dans SPIP
lundi 5 mars 2007 à 17h53 - par  nova06

J’ai oublié dans mon précédent message de vous dire que les vidéos de google fonctionnent très bien que l’on soit sur IE 6, 7 et Firefox 1 et 2.

merci de votre aide.

Logo de nova06
Insérer une vidéo dans SPIP
lundi 5 mars 2007 à 17h45 - par  nova06

Très bien, mais si l’on veut utiliser une vidéo du site dailymotion il y a un problème avec internet explorer 6 et 7. Pour les autres versions du navigateur, je ne sais pas.

Par contre avec Firefox 1 et 2, aucun problème pour voir la (les) vidéo(s) que l’on soit sur PC ou Mac, ce qui est mon cas.

Quelqu’un aurait-il une info la dessus ?

Le site tourne sous spip 1.9.1 [7502] avec sarka 1.9.1 (version précédente à 163)

Logo de fil_ip
Insérer une vidéo dans SPIP
jeudi 1er février 2007 à 14h19 - par  fil_ip

Bonjour,

Il existe aussi un plugins lecteur multimédia qui permet de lire les vidéos mais aussi le mp3.

Plus d’infos ici

J’ai fait un essai sur mon site.

Logo de fil_ip
samedi 9 juin 2007 à 01h15 - par  manmix

bonjour

je vais vous paraitre un peu "même beaucoup débutant mais il faut bien un debut a tout, voila, j’ai inserer le code dans l’article j’ai bien mis le fichier .flv mais rien ne se passe les lien sont bon j’ai fait le test avec un lien basique
je n’ai pas la fenetre qui s’affiche faut il mettre autre chose dans la structure ??

par avance merci pour toute réponse

Logo de manmix
vendredi 2 février 2007 à 10h15 - par  fil_ip

Oups... pardon,
L’essai

Logo de homer67
Insérer une vidéo dans SPIP
lundi 29 janvier 2007 à 18h39 - par  homer67

Bonjour,
J’ai bien essayer d’insérer une vidéo en flv dans mon site mais il n’apparait qu’un espace vide en lieu et place de la video tant attendue. Faut il placer les fichier dans un répertoire particulier du site ou à la racine ?

Merci

Logo de homer67
dimanche 3 février 2008 à 22h47 - par  patboro

Bonsoir, Pascal

Je te remercie d’avoir répondu aussi vite.
J’ai procédé aux vérifications d’usage et j’ai constaté à ma grande honte que le blocage venait de l’absence de chargement d’un plugin.
Il est vrai que je n’utilise jamais IE et la "découverte" que j’ai faite ce soir avait juste pour but de m’assurer que l’application est compatible avec la plupart des navigateurs.
J’ai, depuis, reçu des mesages de membres de l’association témoignant du parfait fonctionnement sous IE.
Je te demande donc de bien vouloir m’excuser pour cet appel à l’aide intempestif, tout en te remerciant une nouvelle fois pour ta réactivité.

Salutations.

Patrick

Logo de patboro
dimanche 3 février 2008 à 21h33 - par  NoNosS (Pascal)

Bonjour Patrick,

j’ai visualisé la vidéo du lien que tu donnes dans ton message avec Internet Explorer 7.
Tout fonctionne normalement.
Essaie de visualiser des vidéos du même type sur d’autres sites (par exemple : celui-ci), avec Internet Explorer, afin de savoir si c’est IE qui est "malade", ou si c’est ton site SPIP qui est en défaut.

Pascal

Logo de NoNosS (Pascal)
dimanche 3 février 2008 à 21h12 - par  patboro

Bonsoir à tous.

J’ai bien suivi les instructions données dans les différents posts et je suis arrivé sans difficulté à intégrer une vidéo à un article.
Si tout fonctionne à merveille avec Firefox, il n’en va pas de même avec Internet Explorer 7.
Quelqu’un aurait-il une idéee pour débloquer la situation ?

Merci d’avance.

Patrick

Logo de patboro
lundi 12 février 2007 à 21h20 - par  ptigars

Il faut juste enlever l’espace avant les points d’interrogations (?).

Navigation

Articles de la rubrique

  • Insérer une vidéo dans SPIP