Mise à jour site sous anciennes versions SPIP et SARKA-SPIP

lundi 24 septembre 2012 à 01h11
par phil77

Logo de phil77

Bonjour,
J’utilise depuis 2005 (déjà) SPIP et Sarka-SPIP pour mon site (de parents d’élèves).

Je suis avec SPIP 1.9.2e et le squelette Sarka-SPIP 2.0.2. Cela date vraiment, je sais...
Je souhaiterai aujourd’hui mettre à jour tout çà avec les dernières versions pour améliorer le site.

Comme je ne veux pas faire n’importe quoi, j’aimerai connaitre les étapes intermédiaires pour mettre à niveau l’ensemble... vers les dernières versions de SPIP et Sarka... Sans tout perdre, évidemment.

Je ne suis pas un expert. Merci de vos lumières, et encore merci à tous les développeurs. C’est un plaisir de travailler avec ces outils très pratiques pour un néophyte comme moi.

Philippe.


Réponses

2 octobre 2012 à 19h12

Hello,

C’est pas jeune comme installation !

Alors je pense que tu devrais déjà faire un test de migration en local. Pour cela il faut que tu aies un environnement serveur web, php, mysql sur un de tes ordis perso. Ensuite tu fais une sauvegarde complète de ton site sur ton ordi à savoir :

  • la base de données sql que tu exportes complètement (structure + données) par phpmyadmin et non par le dump de SPIP.
  • le contenu des répertoires config/, IMG/ et squelettes/ si tu as fait des personnalisations.

Maintenant, tu installes sur ton ordi local un SPIP tout neuf en suivant les articles de ce site si besoin. Je te conseille de passer directement en SPIP 3.0 inutile de passer par un SPIP 2. Tu importes ta base sauvegardée avec ton phpmyadmin local.et tu vas dans ton admin SPIP : ’étape de migration de la base se lance, c’est le moment délicat où ça peut merder. Si tu retrouves tes articles entiers et tout le reste tu peux peaufiner la configuration de SPIP en prenant le temps de découvrir la nouvelle interface.

Ensuite tu installes dans le répertoire plugins/ le squelette Sarka-SPIP en version 3.2. Là aussi il va te falloir un peu d’apprentissage pour retrouver tes petits et comprendre toutes les nouvelles fonctionnalités de Sarka-SPIP 3. Une fois comblé tu peux migrer ton site distant.

10 octobre 2012 à 02h51

Bonsoir,

Merci pour ces infos.
La migration s’est faite sans problème. Un copain plus aguerri que moi m’a filé la main, et, grace à vos conseils, tout s’est bien passé.
Il ne reste que quelques bugs d’affichage à corriger... Des problèmes d’accents et de ponctuations qui s’affichent mal notamment dans les "chapeaux" des articles. Mais la mise à jour des champs va être faite. Avec quelques nouveaux plugins, le site va prendre un coup de jeune.
Merci encore. La prochaine fois, j’attendrai moins longtemps pour les mises à jour.

11 octobre 2012 à 16h57

Si j’ai bien compris, il s’agit de faire un essai en local et si tout va bien on refait la même chose sur son site hébergé ? J’ai un site établissement hébergé sur un serveur académique.

Je suis en
spip 2.1.10 [17657]
Sarka-SPIP 3.0.7 [50083]
et php 5.2.10

est ce que je peux migrer directement en spip 3 avec Sarkaspip 3.2 ?

Mon site concerne plus de 500 élèves sans compter les personnels et les visiteurs professionnels. Je ne voudrais pas faire d’erreur irrécupérable.

J’ai bien compris la démarche expliquée par _Eric_ cependant je voudrais quelques précisions :

- lorsque je fais une importation de la base pas besoin de paramétrage ? (j’ai coché structure et données) j’obtiens un fichier avec extension .sql)

- Au cas ou j’ai tout sauvegardé le site par ftp. J’ai juste besoin des 3 dossiers config/, IMG/ et squelettes/ ?

Si je veux faire une migration il faut que je procède comment ?
étape 1 : je met le plugin sarka 3.2 par ftp sur mon serveur ?
étape 2 : je met ensuite spip 3 par ftp

ou

je fais une install sur mon pc en local et dans ce cas là je ne sais pas trop quoi faire ensuite pour déposer les bons dossiers sur mon serveur via ftp..

désolé si j’ai loupé l’install "pas à pas" sur un autre post je m’en excuse. Mais c’est la 1ere fois que je gère une migration de ce genre.

Je sais pas si c’est utile je donne adresse du site http://lyc-turquetil.scola.ac-paris.fr/. A priori j’ai toutes les infos pour gérer une telle migration (infos ftp et phpmyadmin)

En vous remerciant pour votre aide
Et encore bravo pour le taff

Mise à jour site sous anciennes versions SPIP et SARKA-SPIP
15 octobre 2012 à 10h00

Bonjour Pascal,

Suis les indications de ce post : http://www.sarka-spip.net/spip.php?...

18 novembre 2012 à 22h49

migration vers spip 3.0.5 et sarkaspip 3.2.9 depuis spip 2.1.12 + sarka 3.0.8
un petit compte rendu de ma migration faite ce jour :

avec une connection satellite j’ai pris le risque de faire au minimum ( copie avec filezilla avec ecrasement des fichiers existants, vidage des fichiers anciens sous / et /config , sauvegarde par dump sans utiliser phpmyadmin )

d’abord chapeau et encore une fois merci , au final ca fonctionne parfaitement , sauf 1 détail listé ci dessous. ( url )

mais je me suis fait des sueurs froides, planté sur err 404 pour accéder à l’espace
privé après saisie des parametres sql

en fait il s’agissait de fichiers mal copiés, toujours cette liaison satellite, j’ai du me rapprocher de la civilisation pour disposer d’une connection adsl et tout est rentré dans l’ordre en ré écrasant une deuxieme fois l’arborescence spip3 sur la racine du serveur

aprés j’ai passé beaucoup de temps sur la gestion des images , j’avais lu sur les forums
que mediabox ( intitulé "boite multimedia dans le choix squelette, remplacaient fancybox et nyroceros qui ne seraient donc pas portés sous spip 3.0 , effectivement affichage plugin incompatible si on tente de les activer )
Et ca fonctionnait parfaitement sur les articles migrés de la 2.1 , mais pas sur celui que j’ai rédigé sous le 3.0 : en fait il y a une mauvaise documentation de spip 3.0 aggravé par un petit bugg : quand vous "téléversez" votre image ou document , il se met dans le porfolio ( c’est un choix .. ) et il vous propose de l’integrer dans l’article avec un préfixe doc =
il faut faire "retirer du portfolio pour qu’il le prenne comme une image gérée par mediabox avec un préfixe img . mais si vous modifiez le titre ou une autre description , le fichier passe en docXXX , et mediabox ne le gére plus !!

enfin le dernier détail , je ne sais pas dire si c’est un pb spip ou sarka :

- gestion url "arborescentes" sous spip 2.1.12 j’avais choisi ( dans fonctions avancés de config ) le choix "url propres en query string" et modifié le titre de mes articles pour que l"url soit plus "parlante" . sous 3.0.5 j’ai opté pour le choix "url arborescentes" , qui fonctionne bien, sauf qu’y figure l’ancien titre de mes articles ( qui a été modifié sous 2.1.12 ) . Il semble donc y avoir 2 champs titre dans la base , et ce n’est pas le bon ( modifié en édition ) qui est affiché .

Bonsoir à tous, je crois que vous pouvez y aller sans craintes !!

18 novembre 2012 à 23h16

Un oubli : il y a un autre plugin compatible spip 3 et sarkaspip 3.2.9 : c’est piwik ( successeur de php myvisite ) , et çà marche parfaitement !!
Le module statistique de la 3.0 à l’air de fonctionner aussi, mais est moins détaillé qu’auparavant, ce qui valide le choix de piwik en complément ..
A voir à l’usage si les pb de non remise à zéro dans les stats intégrées à spip 2.1 sont résolus ...

21 novembre 2012 à 18h29

Suite au message de Jean-marie concernant médiabox.
moi je n’y arrive pas. j’ai tout essayé pour que ça fonctionne. J’ai suivi tes conseils, mais rien n’y fait, toujours un affichage de l’image en haut à gauche.
J’ai enlevé du portfolio et récupéré en img... rien
j’ai validé et dévalidé le paramétrage compabible entre sarka et médiabox... rien
Je tourne en rond, sans résultats...
qu’en penses tu ?
Merci
Thierry

22 novembre 2012 à 08h20

essaye de
- réinitialiser le paramétrage de "boite multimedia" dans config
- vérifier que ton insertion dans le texte est bien sous la syntaxe <imgXXX|center> , ou
<imgxxx|left[taille=TTT> ( su tu a fait l’insertion par un cpier coller après avoir modifié
les paramètres de l’image , le bigg que j’au relevé t’a mis <docXXX|center>

22 novembre 2012 à 17h25

J’ai bien

img171|center

dans le corps de mon message, mais rien n’y fait !
voici le lien qui me pose des problèmes.

http://ec28.fr/spip.php?article8
je pourrais te donner un accès si tu veux y jeter un oeil.
Merci
Thierry

25 novembre 2012 à 09h28

Tlambillard,

Pourrais-je avoir un accès webmestre pour vérifier que tout est ok sur ton site stp ? Si oui, envoie moi ça par mail privé.

Sinon je viens d’y penser as-tu bien rempli la configuration de l’effet dans la page « Modèles » ?

29 novembre 2012 à 15h41

Bonjour,

je souhaiterais faire une installation sur un hébergeur free pour ne pas le nommé !
un spip 3.0.5 + sarka 3.2

mais voilà le message qu’il me donne :
Attention : main (ecrire / inc_version.php) [ function.main ] : failed to open stream : Aucun fichier ou répertoire dans / mnt/169/sdb/c/c/compiegnevolley/spip.php sur la ligne 15

Avertissement : main ( ) [ function.include ] : ’ecrire / inc_version.php’ ouverture Failed for inclusion (include_path = ’/ mnt/169/sdb/c/c/compiegnevolley/include :. :/ usr/php4/lib/php’) dans / mnt/169/sdb/c/c/compiegnevolley/spip.php sur la ligne 15

Avertissement : main (ecrire / public.php) [ function.main ] : failed to open stream : Aucun fichier ou répertoire dans / mnt/169 / sdb / c / c / compiegnevolley / spip.php on line 24

Warning : main () [ function.mysql ] : ’ecrire / public.php’ ouverture Failed for inclusion (include_path = ’/ mnt/169/sdb/c / c / compiegnevolley / include :. :/ usr/php4/lib/php ’) dans / mnt/169/sdb/c/c/compiegnevolley/spip.php sur la ligne 24

est-ce que c’est la version du php que cela ne passe pas ?
est-ce que j’ai une chance de pouvoir l’installer en procédant a des changements ?
ou dois-je revenir a une versions antérieure ?

Te remerciant de ta réponse bien évidement et bravo encore pour tout le travail que vous faites

29 novembre 2012 à 21h26

Je ne suis pas expert ! Mais j’ai testé, sans problème, l’installation de Spip 3 et Sarka chez free :

les coordonnées suivantes me sont données :

Sarka-SPIP 3.2.5 [67422]
SPIP 3.0.5 [19905]
PHP 5.1.3RC4-dev

Bonne chance donc avec la manip.htaccess

7 août 2013 à 12h31

Migration SPIP 2.1.10| Sarka-SPIP 3.0.8 vers SPIP 3 /SARKA 3.2

Bonjour, je profite de cette période du mois d’août pour faire du e-ménage....
cela concerne le site http://lycee-valin.fr

il est SPIP 2.1.10 [17657] | Sarka-SPIP 3.0.8 [54368].
je compte faire une migration afin de pouvoir profiter des nouveautés qu’apportent ces versions.
Quelle est la manip à réaliser sachant que ce site fonctionne depuis qq années et je ne voudrais pas perdre son contenu..
- J’ai fait une sauvegarde de la base de données (depuis le site, en XML et une autre depuis l’hébergeur en SQL.
- J’ai installé un SPIP tout neuf dernière version dans un dossier nommé BETA chez mon herbergeur (PlanetHoster).
- J’ai copié le dernier SAKRA dans le dossier plugins/auto/
- J’ai créé un sous-domaine http://beta.lycee-valin.fr qui pointe vers ce nouveau SPIP. Pour ne pas toucher à la version actuelle du site.

Qui peut m’aider à faire cette migration majeure sans encombre ?

Merci Patrick

7 août 2013 à 13h53

Salut Patrick,

Si tu as rajouté ton message dans ce thread c’est que tu as lu déjà lu mon explication initiale. Donc je confirme que tu es sur la bonne voie.

A partir du moment où tu as un dump SQL (pas le XML qui n’est pas fiable) tu ne perdras pas tes données.

Si tu ne l’as pas encore fait, crées une base en interclassement UTF-8 par phpmyadmin pour ton site beta. Il te faut aussi depuis ton site initial copier le contenu des répertoires config/, IMG/ et squelettes/ dans l’arborescence de ton site beta. ATTENTION, le fichier config/connect.php contient la référence à ta base de production : modifie-le absolument avec le nom de la base beta avant d’entrer dans ton site SPIP. Ensuite, avec phpmyadmin, tu importes ton dump SQL dans ta nouvelle base beta.

Supprime aussi le plugin sarka-spip que tu as mis manuellement sur ton site beta. On le remettra avec SPIP 3 plus simplement. Et crée si il n’existe pas encore un répertoire plugins/auto et lib/ avec les droits 777.

Là tu es prêt à rentrer dans ton site. Tu te loges avec ton login habituel (puisque tu as le même contenu que celui de ta base initiale) et tu va voir s’afficher un message qui te demande de lancer l’étape de migration de la base. Tu dis oui et la migration se lance, c’est le moment délicat où ça peut merder. Si tu retrouves tes articles entiers et tout le reste tu peux peaufiner la configuration de SPIP en prenant le temps de découvrir la nouvelle interface.

N’oublie pas d’aller dans la configuration "identité du site" pour modifier l’url de ton site vers ton domaine beta sinon tu vas revenir à chaque fois dans ton site de production.

Si tout est ok, tu vas dans l’administration des plugins (ajouter plugins) et on va ajouter les plugins un par un. L’administration des plugins a changé et un outil permet de charger et mettre à jour automatiquement les plugins (sauf sur Free). Tu crées d’abord le dépôt de plugin en validant le formulaire prérempli (attention ça peut durer un moment). Ensuite tu vas dans ajouter des plugins et avec le formulaire de recherche tu cibles les plugins que tu souhaites ajouter. Attention, l’état est par défaut à stable, mets le sur tous les états car certains plugins comme Sarka-SPIP sont en "test".

Clique sur "télécharger et activer" et tout ce fait tout seul. Mets d’abord le squelette, teste et ensuite, mets les autres plugins un par un. Le nouvel outil de SPIP gère lui-même les dépendances.

Voilà, dis moi si ça marche ensuite...

7 août 2013 à 15h08

GRAND merci Eric !
c’est une grande avancée....
Seul le plugin THUMBSITES générait un message d’erreur, je l’ai désactivé, cela fonctionne sans lui... normal ?
il me reste plus qu’a trouvé le moyen de créer un forum dans l’espace public tel que celui que tu as créé mais qui ne soit accessible que pour certaines personnes à qui je donne accès.

Le travail (de néophyte) continue pour moi...

7 août 2013 à 15h26

Pour Thumbsites, la solution est là : http://www.sarka-spip.net/spip.php?.... Tu vois ça sert les forums ;-) !

Regarde la petite doc que j’ai faite sur les forums. Pour donner un accès restreint, je pense qu’il n’y a pas d’autre solution que de placer ce forum dans un secteur restreint puisque c’est un secteur spécialisé.

7 août 2013 à 15h39

Merci Eric, en effet plus d’erreur sur thumbsites.
Par contre je ne retrouve pas ta doc dur les FORUMS....

7 août 2013 à 15h46
7 août 2013 à 16h12

En activant le forum depuis la config SARKA, j’ai ce type de message d’erreur... cela te dis qqchose Eric ?

forum.png
7 août 2013 à 16h17

Non, je vois pas d’où ça vient. Tu n’as pas des personnalisations ?

Sinon j’aimerais bien qu’on arrête ce thread car sinon le rangement ne servira plus à rien. Si tu as un nouveau problème crée un fil pour cela dans la bonne rubrique stp.

2 octobre 2013 à 19h00

Bonjour Eric,
je viens de mettre HS le site assouevam.fr qui marchait si bien en 3 clics idiots.
j’étais en 3.2
Je vais faire un tour sur les plugins , je ne réfléchis pas, je vois, 4. 3.je clique. Catastrophe. Le site a complètement changé. Il faut trevenir en arrière.
je clique désintaller Boostrap =>fatal error. Le site est sans dessus dessous, encore pire.
J’e desintalle comments. Refatal error : l’ensemble n’a plus ni queue ni tête.

Comment faire pour, par exemple réinstaller une sauvegarde d’il y a 15 jours ?
Je n’ai jamais fait ça.
Ou y a-t-il une autre possibilité qui ne ferait pas perdre les dernières contributions du site qui voit passer 4 à 500 personnes par jour maintenant.

Je suis impardonnable, je sais, mais peux-tu quand même venir à mon secours ?

2 octobre 2013 à 20h36

Salut Soueva,

Pas d’inquiétude, rien est cassé. C’est juste une histoire de squelettes. Il faut juste faire le ménage avec ton FTP et supprimer les plugins nouveaux et réinstaller manuellement la version 3.2 ou 3.3 de Sarka-SPIP.

2 octobre 2013 à 20h50

Re Soueva,

J’avais encore les coordonnées du site donc j’ai fait le ménage et rétabli la version 3.2.24 de Sarka-SPIP. Je voulais mettre la 3.3 mais je sais plus si tu as des personnalisations dans le répertoire squelettes/. Envoie moi le login FTP et je vérifierais et je te ferais la mise à jour.

Par contre, vérifie si tu n’as pas perdu quelques configurations. Si oui, pas de panique il suffit de les refaire.

Tiens moi au courant.

2 octobre 2013 à 23h06

Merci Eric,
Au début j’ai pas compris que t’étais passé et j’ai cru à un miracle !!!!
Merci beaucoup, Eric, de ton intervention, je n’en menais pas large.
le site a retrouvé sa lisibilité.
Je suis donc allée sur les plugins et j’ai encore viré Z-box.
Bian ; il manque la partie basse du bandeau qui contenait les menus forum (mais dans la partie privée, le forum n’a pas bougé),"agenda", et "sur le web".
il manque aussi la partie haute du bandeau avec l’image du nom et le logo et le slogan
Il me semble que je n’avais pas les derniers articles en page d’accueil mais le plan du site dans son entier
lLa colonne de droite a donc perdu son agenda, les derniers commentaires du forum et les sites web amis..
la colonne de gauche a perdu "contact"
A première vue, c’est tout.
je t’envoie en direct le ftp et le mdp.
Encore merci.

4 octobre 2013 à 10h31

Bonjour Eric,
J’ai reconfiguré Sarka-spip et le site a retrouvé son look, ouf ! :
Cependant, il reste qq problèmes qui ne semblent pas provenir des réglages de la configuration de Sarka-spip ou de spip dans la partie privée mais peut-être de mes malencontreux clics d’avant-hier :
- La bannière et le logo continuent à ne pas vouloir s’afficher, bien qu’ils soient présents dans /squelettes/images.
- le panorama des sites favoris qui tournait en colonne Extra. Son réglage est en grisé dans la configuration à la rubrique Sites favoris.

Pourrais-tu me donner un avis ?
Penses-tu que le fait de mettre à jour la dernière version de spip et la 3.3 de Sarka pourrait améliorer les choses ?

4 octobre 2013 à 21h59

En fait, tout est rentré dans l’ordre en configurant Sarka sans rien oublier .
Merci

4 octobre 2013 à 22h04

Bon cool !

Il ne faut jamais stressé avec le squelette. Il n’agit pas sur la base de données donc on peut tout au plus perdre la configuration mais cela se refait.

Donc une petite sauvegarde de la configuration avec l’outil de maintenance du squelette et la c’est la tranquillité assurée ;-).

24 octobre 2013 à 16h11

Bonjour,

C’est l’occasion : changement de nom de domaine, mises à jour SPIP (3.0.11) et SARKA-Spip (3.2.28), et si j’essayais SARKA-Spip 3.3 ... Retour vite fait en 3.2, après avoir vu que sommaire.html c’est pas du tout la même chose en 3.2 et 3.3. Y-a du boulot en prévision, et il faut travailler en local !

Une vingtaine de fichiers du répertoire éparpillés dans huit sous-répertoires supplémentaires, ce n’est pas rien. Merci de nous préparer à la version 4 ! Mais sans nous mâcher le travail, ce serait sympa de nous expliquer ce qui change dans le principe, par exemple pour comprendre par quoi est remplacé le fichier bandeau.html.

Bon, je n’en suis qu’au début. J’ai toujours beaucoup appris avec vous depuis 6 ans, et là, je sens que le niveau va monter d’un gros cran. Il faut vous suivre !

Cordialement.

25 octobre 2013 à 11h52

Bonjour,

Je tente d’abord le passage à sarka 3.3 avec Z-Core aussi.
Mais j’obtiens le message suivant : voir pièce jointe.
Merci pour toute suggestion.

capture_d_e_cran_2013-10-25_a_11.45.26.png
25 octobre 2013 à 20h31

@alegall :

Il ne trouve pas le fichier structure.html. C’est donc que le plugin zcore n’est pas activé.

25 octobre 2013 à 20h39

@hdeb :

Passer de la 3.2 à la 3.3 devrait se passer sans problème pour tous les utilisateurs qui n’ont pas de fichiers de personnalisation. Ca a été le cas sur ce site car j’utilisais exclusivement les pipelines pour rajouter des noisettes.

Néanmoins, pas mal d’utilisateurs ont petit à petit modifié les fichier extra.html et navigation.html, les fichiers du bandeau ou de certaines pages. Dans ce cas oui, le passage à la 3.3 demande un peu de travail mais pas tellement et surtout la maintenance est bien plus simple quand on veut modifier l’ensemble des pages par exemple.

Je vais essayer de proposer un article de migration ce week-end. Je sais aussi qu’il y a quelques bugs de remise à zéro de certaines pages de configuration mais c’est léger et toujours réparable en particulier si on pense à sauvegarder ces pages avant la migration.

25 octobre 2013 à 21h50

Merci d’avoir répondu : je ne pense pas avoir changé grand chose (j’ai une image en guise de bandeau et donc un fichier "squelettes" à la racine).
Le plugin zcore est bien activé : voir pièce jointe d’une copie écran.
Merci pour ce peaufinage en cours.

capture_d_e_cran_2013-10-25_a_21.45.50.png
18 novembre 2013 à 13h05

Bonjour les amis,
J’ai bien Transféré par un dump le site intranet de mon entreprise en local sur mon PC sur mon bureau , j’ai bien installé les deux même versions de spip2.1.23 (pour une mise à jour après passage à spip3 à faire ensuite ...)
Dans l’ espace privé en local sur mon bureau tout marche bien le transfert des donnés s’est bien passé par dump et ftp
(effectivement mon mot de passe de identifiant et connexion qd j’ai installé spip2.1.23 a été perdu j’utilise celui de site intranet de l’entreprise ce que j’avais bien lu dans les forums) Le squeltte sarkaspip et CFG s’installent bien aussi j’ai aussi transféré le dossier plugins
>Mais dans la partie espace public de spip en local, et aussi sur sarkaspip3 (beta2) les liens bien qu’affichés comme dans l’espace privés de ne pointent pas du tout sur l’espace privé ou en affichage public ou sur sarka, tous les liens sont brisé, cela m’affiche
Le même erreur tout le temps sur tous les liens :


Not Found

The requested URL /spip2.1.23/rubrique82.html was not found on this server.


Que dois je faire svp je n’ai pas touchés encore au fichiers de conf. mon fichier de connect.php me met bien mes info de connexion à ma base en local que j’ai crée licalhost, root, MP de connexion à la base, nom de tables etc comme ceci :
< --------------- >
<?php
if (!defined("_ECRIRE_INC_VERSION")) return;
define('_MYSQL_SET_SQL_MODE',true);
$GLOBALS['spip_connect_version'] = 0.7;
spip_connect_db('localhost','sarkaspipmon','root','5xxxxx','','mysql''sarkaspipmon','');
?>

< --------------- >

Merci de votre aide c’est URGENT
Firouz

18 novembre 2013 à 14h14

RE,
Une personne m a ’ répondu je donne la réponse,
Aller dans ;
configuration fonctions avancées etc.
mettre les nouveaux renseignements pour le site en local
http://
et surtout enlever le .txt de htaccess à la racine
Par contre les doc joints et les images posent le même type de pb

Firouz

20 décembre 2013 à 11h31

MISE A JOUR DE SPIP ET SARKASPIP, NOV DEC 2013
Bjr tout le monde et Bjr Eric, merci pour votre ton travail ici à tous. Je reviens vers vous vers toi car j étais en formation
Je travaille dans un Établissement (public) de recherche sur Paris
J’ai pu utilise le plugin migration pour faire un transfert de site et je le conseil
http://www.nursit.com/Le-plugin-migration-pour-SPIP c’est un Plugin gratuit

PROBLÈMES :

- Mais tout na pas migré en une fois
- Ensuite j’ai fait une importation à la main de tous les fichiers de IMG de site spip (n- 1) à spip (n) le squelette que j’ai ajouté après avec ajout est notre plugin sarkaspip.
Toutefois le pb que j’ai c’est que **la page de garde de ce site spip et notre modèle associé sarkaspip est Incomplet**
Tout ne s’est pas affiché. Sur le site d’Origine il y a un logo et il y a un paragraphe avec prés de 8 lignes chacun-es renvoyant à un lien interne doc pdf ou word etc. qui sont absent complétement.
- Je crois me souvenir c’est peut être la technique spip ou sarkaspip de passage d’un page article de site spip en page de ->garde de site il y a une formule à appliquer, (je ne sais plus comment on faisiat) et ici pourquoi ceci ne s’est pas mis en place correctement lors de migration avec votre plugin svp...)
Dans une cope intelligent locale que j’avais fait pour ne pas travailler sur le site de production tout c’ était bien Passé il y a bein cette page de garde.
>Voici les versions de site spip (x - 1) et spip (x) avec nos squelettes (n - 1) et squelettes (n) en rapport utilisés :


***spip3.0.5 et sarkaspip 3.2.36***.
***spip2.1.24 et sarkaspip3.0.0 beta***


Autres question par rapport à Sarkaspip Nouveautés ;
Quelle est la version de sarkaspip ou il y a formulaire de contact avancé intégré ou generateur de formulaire comme plugin et aussi un forum complet que je puisse mettre en oeuvre ici c’est dans quelle version de sarka et se marie avec quelle version de spip
Questions
Pouvez vous m’aider à résoudre ce pb de page de garde ou tout ne s ’affiche pas et les versions sarka qui marchent bien qui ont fait leur preuve avec Grand forum, et Generateur de formulaire avencé et autres choses interessantes
qu’on DOIT UTILISER ICI ILS SOUHAITENT BIEN (les responsables !)
tres cdt
M Firouz (Obs Paris)
tel 01 40 51 20 81

23 décembre 2013 à 19h13

Bsr,
Je me réponds à moi même
Pour la p° sommaire édito, p° de garde de site avec logo et tout cela
C’est tjrs le même problème
il faut remplacer dans le groupe de mot clés :
squelette_habillage
le mot clès : ’edio’ , qui n’est plus bon par ;
’artcile_une’ qui est le bon mot
Bonne fête de fin fannée

23 décembre 2013 à 19h19

Bsr,
J’ai pu utilise le plugin migration pour faire un transfert de site et je le conseil

http://www.nursit.com/Le-plugin-migration-pour-SPIP c’est un Plugin gratuit

Lisez aussi les 2 articles de Stéphane Bretagne sur le mise à jour de spip et de sarka et la sauvegarde de ces deux CMS et modele
Si non lire l’artice de spip.net ;
’Mise à jour 1.9 vers 2.0 ’qui explique bien ou on comprends bien mais qui est trop vieux (voir aussi la suvegarde de spip dans spip.net)
Refaire tjrs une copie" intelligente" de site en local avant de toucher au le site de production ou de le laisser tout simplement.
cdt

26 décembre 2013 à 21h06

Je ne sais pas si je commence une question ou si c’est à la suite !

J’avais un problème page blanche en espace privé quand j’essayais de revenir sur l’article (en édito) pour le modifier. Plus moyen d’intervenir dessus et il était néanmoins visible sur le site public (mais avec des défauts que je voulais corriger). J’étais en spip 2 et sarka.

Je me suis dit : peut-être que cela va se résoudre en migrant tout vers spip 3 et sarka 3.2. J’appréhendais mais cela a marché.

http://association.aspec.free.fr/

Merci pour toute piste !

(Je vais être absent 3 jours).

A. Le Gall

Néanmoins pour l’article édito de la page d’accueil, le problème de la page blanche en espace privé demeure idem !

Par exemple plus possible d’intervenir sur l’image qui déborde… ni d’ajouter du texte…
Cela donne ce message en copie d’écran

Si dans Sommaire de la configuration Sarka je choisis un ancien édito, cela passe et je peux intervenir dessus…

capture_d_e_cran_2013-12-26_a_20.55.32.png
27 décembre 2013 à 11h23

Bjr,
Je ne sais pas, mais vous avez regardé vos mots clés peut être et les groupes de vos mots clés
cdt

27 décembre 2013 à 11h54

Hélas je n’y ai plus accès pour regarder !
Merci.

16 juillet 2014 à 09h46

Bonjour,

Je viens d’installer Sarka-SPIP 3.4.1 [82905]

La sauvegarde de la configuration de SARKA ne se fait plus dans tmp/cfg mais dans
tmp/sarkaspip/config.
Le plugin mes_fichiers, ne sauvegarde pas cette arborescence.
Suffit-il de surcharger le fichier sarkaspip_pipelines.php en remplaçant la ligne :

$tmp_styles = defined('_DIR_TMP') ? _DIR_TMP.'cfg/': _DIR_RACINE.'tmp/cfg/';
$tmp_styles = defined('_DIR_TMP') ? _DIR_TMP.'config/': _DIR_RACINE.'tmp/sarkaspip/config/';

Je ne connais pas PHP j’ai juste essayé d’évaluer le code par similitude.

Ou y a-t-il un autre paramétrage permettant de la faire plus simplement.

Merci

16 juillet 2014 à 09h51

Désolée, j’ai posté cette question au mauvais endroit, ne pas en tenir compte, j’ai ouvert un nouveau sujet

16 juillet 2014 à 10h34

Bjr,
Une installation de spip3.0.5 avec sarka3.2.36 marche bien chez moi
Au dela de sarka3.2.36 a savoir sarka 3.3 ou 3.4 les choses changent beaucoup
(Il ya une page de sarka consacrée à toutes le smodif à faire au dela de sarka3.2)
Je n’ai pas essayé.
cdt
M Firouz

11 août 2014 à 15h22

Bonjour,

Je voudrais (enfin !) essayer SPIP3 et Sarka SPIP 3.4 mais pas moyen de le télécharger : sur tous les liens (sur ce site et sur SPIP contrib) me donne que la version n’existe pas ou a été déplacée.
la version 3.3 n’est plus accessible non plus.

11 août 2014 à 15h43

Salut,

Je comprends pas ce que tu dis elle est accessible sur les liens de téléchargements en page d’accueil et en utilisant le chargeur automatique dans SPIP 3 tu las récupères sans problème non ?

11 août 2014 à 15h44

Bonjour,

Aujourd’hui, le lien http://files.spip.org/spip-zone/sarkaspip_3x.zip
pointe sur : Sarka-SPIP 3.4.3 [83686]

11 août 2014 à 15h49

merci et pardon : oui, je cliquais bien sur le lien ci-dessus, et quand je faisais "enregistrer sous", cela me disait que cela était déplacé ! Il suffisait d’insister et de cliquer sur recommencer.

Je fais mon test sur Free donc pas de chargement auto hélas.

6 février 2015 à 13h29

Pour un non spécialiste mais usager simple de spip et sarka, est-il possible de faire la transition de spip3 avec squelette sarka des versions "classiques" d’avant (Spip3.0.17 et Sarka 3.2.36) à SPIPr et sarkaspip v4 ?
Y-a-t-il un tutoriel abordable pour la marche à suivre. Je n’ai jamais pu aller au-delà de sarkaspip 3.2.36 !
Jusqu’à présent, j’arrivais à être autonome en la matière !

Merci

A. Le Gall

2 mars 2015 à 18h01

Bjr quand j’installe les versions anciennes suivantes
de spip2.1.26
et sarka spip 3 ou sarkaspip3.1.4 en vue d’une copie d’une ancienne site
Dans le menu de configuration plugin de sarkaspip (espace privé de spip)
A chaque fois que cela soit avec sarka3 ou sarka 3.1 4 j’onbtines un message d’erreur sur la page de configuration de sarka dans espce privé donc ceci


SCREAM : Error suppression ignored for
( ! ) Strict standards : Only variables should be passed by reference in C :\wamp\www\spip2.1.26\plugins\auto\cfg\inc\cfg.php on line 216
Call Stack
# Time Memory Function Location
1 0.0011 289064 main( ) ..\index.php:0
2 0.0739 2557008 exec_cfg_dist( ) ..\index.php:156
3 0.7976 13011848 cfg->liens( ) ..\cfg.php:73
=====================================================
JE L’ AI 27 FOIS JE SUPPOSE CEA CORRESPOND AUX ITEMS DE CONFIGURATION DE SARKA QUI SONT TOUTEFOIS LA EN DESSOUS
SVP que faut t 6 il faire pour corriger cette erreur pour mon travail,
Avnt je n’avais pas ce type de message c’est la 1 ere fois que j’ai cela merci à tous (firouz)

12 juin 2015 à 11h21

Bjr,
Suite à un détour ((après des vicissitudes personnelles hélas))
La mise à jour de spip
Pour, refaire une nouvelle mise à jour de site spip intrant,
De passage de spip2.1.26 à spip 3.0.16 et sarka spip3.2.36 en lien donc une mise à jour majeur (une 2de fois donc que j’ai refait la chose) c’est bien réalisée.
Avec une nouvelle méthode ; manuelle de : CNRS.
- faire une copie intelligent complète de site en local le refaire à l’identique donc en fait
- appliquer les instructions les procédures de mise à jour majeur de CNRS etc.
Travail (re) fait en local (je n’ai pas encore tout vérifié mais tout me semble être normal à 1ere vue,((des vérifications sont encore nécessaires, je pense etc...))


Forum sur abonnement

Pour participer à ce forum, vous devez vous enregistrer au préalable. Merci d’indiquer ci-dessous l’identifiant personnel qui vous a été fourni. Si vous n’êtes pas enregistré, vous devez vous inscrire.

Connexions’inscriremot de passe oublié ?