Débusquer la nouvelle branche 4.0 pour SPIP 4

mardi 28 décembre 2021
par  _Eric_
popularité : 1%

Ce forum est dédié à la mise en oeuvre de la nouvelle branche 4.0 de Sarka-SPIP pour SPIP 4. Comme toute version nouvellement développée elle peut-être l’objet de bugs, de regressions ou d’oublis même si de nombreux tests ont été effectués.

N’hésitez à utiliser ce forum pour remonter vos problèmes de migration et de fonctionnement. Néanmoins, avant toute migration, veuillez lire attentivement l’article Passer à Sarka-SPIP 4.0.0 pour SPIP 4.


Commentaires

Logo de jmax
compatibilité spip 4.1
mercredi 30 mars 2022 à 08h01 - par  jmax

Bonjour,
Après une longue interruption, je viens de SPIP 2.1.30 pour me mettre à jour. Je me suis mis au dernier niveau spip, soit le 4.1, et il semble que le dernier sarka-spip est incompatible.
Est ce que Sarka-SPIP 4.0.0, Squelette généraliste et hautement configurable, version incompatible, est vraiment incompatible et j’ai juste à attendre ou bien, est ce que mon rafraîchissement de site aurait foiré ?
Merci pour vos éclaircissements.

Logo de jmax
jeudi 31 mars 2022 à 18h37 - par  _Eric_

Quand j’ai sorti cette branche pour SPIP 4.0 la version 4.1 n’était pas disponible. Donc je n’ai pas testé.

Maintenant il y a de forte chance qu’elle fonctionne avec un spip 4.1. Pour vérifier il suffit de forcer la compatibilité des plugins avec spip 4.1 en ajoutant dans le mes_options.php de ton site la ligne suivante :

Ca permet de faire fonctionner tous les plugins compatibles 4.0 dans le spip courant soit 4.1.
Ensuite il faut tester si il n’y a pas de bugs.

Logo de enas foititis
Sarka-SPIP Reloaded
samedi 29 janvier 2022 à 10h07 - par  enas foititis

Bonjour,

Est-ce-qu’il y aura un jour une version compatible Sarka-SPIP Reloaded pour Spip 4.0 ?

Bien à vous.

Logo de enas foititis
lundi 27 juin 2022 à 15h14 - par  KaSar

En effet… je n’avais pas remarqué que Zcore en version 2.8.9 était signalé "Obsolète".
J’y ai mis la v3.0.3 et voici le message obtenu :

Impossible d’activer le plugin ../plugins/auto/sarkaspipr/v4.5.12
Nécessite le plugin ZCORE en version ≥ 2.3.0.

alors j’ai remis la v2.8.9, réactivé sarkaspipr v4.5.12 et ça marche (sans la mention "obsolète") ! allons savoir pourquoi…

Logo de KaSar
lundi 27 juin 2022 à 15h06 - par  KaSar

En effet… je n’avais pas remarqué que Zcore 2.8.9 était signalé ’Obsolète" dans la Gestion des plugins.
J’y ai mis la version 3.0.3 et obtenu :

                Impossible d’activer le plugin ../plugins/auto/sarkaspipr/v4.5.12
                Nécessite le plugin ZCORE en version ≥ 2.3.0.

J’ai donc remis la v2.8.9 puis réactivé sarkaspipr v4.5.12 et ça marche… sans "Obsolète" ! allons savoir pourquoi.

Logo de KaSar
lundi 27 juin 2022 à 13h54 - par  enas foititis

@KaSar

Le plugin Comments version 3.5.1 est compatible avec spip 4.0.

Comment faites-vous par contre pour activer le plugin Zcore en version 2.8.9 alors qu’il n’est pas compatible avec spip 4.0 ?

Logo de enas foititis
jeudi 16 juin 2022 à 09h48 - par  KaSar

Donc pas de "thèmes" avec Zen-Garden 2.10.2

Logo de KaSar
jeudi 16 juin 2022 à 09h43 - par  KaSar

Une précision sur les mise à jour Sarka-SPIP et Sarka-SPIP Reloaded.
Si ce denier est disponible SPIP 4.0 et 4.1, Sarka-SPIP ne l’est qu’en 4.0 (pour l’instant).

Logo de KaSar
mercredi 8 juin 2022 à 22h08 - par  enas foititis

@KaSar

Merci de votre réponse.
Bien à vous.

Logo de enas foititis
vendredi 3 juin 2022 à 16h02 - par  KaSar

Bonjour,
Oui, Sarka-SPIP Reloaded est maintenant compatible avec Spip 4.0 et 4.1 grâce à sa nouvelle version 4.5.12 "stable".

https://plugins.spip.net/sarkaspipr.html
mais semble poser des problèmes avec Z-core et Comments

Erreurs survenues
Impossible d’activer le plugin ../plugins/auto/sarkaspipr/v4.5.12
Nécessite le plugin ZCORE en version ≤ 2.*.*.
Nécessite le plugin COMMENTS en version ≤ 3.*.*.
Logo de wiwi
Migration réussie ! (et petite question)
jeudi 30 décembre 2021 à 09h15 - par  wiwi

Bonjour,

Je me suis finalement lancé hier dans la migration de spip 3.12 vers spip 4 et de spip-reload vers sarkaspip 4. Je n’ai rencontré aucun problème. Il m’aura été seulement nécessaire d’aller chercher "à la main" le lien vers le téléchargement de sarkaspip 4, ce dernier n’ayant pas été trouvé via la recherche.

Quel bonheur de retrouver le menu et la navigation de sarka-spip qui, pour mon usage, reste la plus efficace !
J’ai besoin évidemment de réaliser quelques ajustements, mais je ferai cela au fil de l’eau.

J’aurais néanmoins une question : est-il possible de modifier sans trop de difficulté la taille de la police par défaut (car je la trouve un peu petite) ? (même si via le navigateur, un coup de zoom à 110 % et j’obtiens le résultat escompté).

De nouveau mes meilleurs voeux pour 2022 et encore merci pour ce formidable squelette pour spip.

Bien à vous,
wiwi

Logo de wiwi
jeudi 30 décembre 2021 à 14h54 - par  wiwi

Merci de cette réponse. Je crois entrevoir les problèmes que cela provoque dans les menus. Néanmoins, si je puis me permettre, la hauteur des menus de navigation de gauche mériterait d’être un peu plus grande, car la souris a vite fait de légèrement dévier, ce qui provoque souvent la "disparition" des sous-menus si ces derniers existent. Là, avec mon chrome zoomé à 125 %, je n’ai plus ce souci, et ce petit réglage "côté utilisateur" ne me semble pas insurmontable à effectuer.

Je note quand même le css pour un test ultérieur.

Logo de wiwi
jeudi 30 décembre 2021 à 11h47 - par  _Eric_

Hello,

Bon c’est cool tout ça.

Pour la police je me suis dit aussi la même chose. On peut le faire sur l’ensemble du site mais en essayant ça pertube les menus.
Si le seul besoin est grossir les textes des articles le mieux est de modifier la ligne suivante :

en changeant le 1.2em par 1.3 ou 1.4 par exemple.

Bien sur, il ne faut pas faire cela dans le fichier css de sarka-spip directement mais en créant un fichier perso comme cela est précisé dans l’article Les méthodes de personnalisation, paragraphe Adapter les CSS.

Navigation

Articles de la rubrique