Installation du squelette

vendredi 24 juin 2011
par  _Equipe_
popularité : 5%

Avant de poser votre question veuillez lire la rubrique de documentation Installer le squelette et vérifier si la réponse ne s’y trouve pas déjà.

Table des matières de la rubrique

  1. Prérequis à l’installation
  2. Installer un SPIP « tout neuf »
  3. Installer le squelette Sarka-SPIP
  4. Installer les thèmes de Sarka-SPIP
  5. Créer les mots-clés utiles au squelette
  6. Migrer Sarka-SPIP de la branche 3.2 à 3.4 ou ultérieure

Ce forum est dédié aux questions relatives à l’installation de Sarka-SPIP, à savoir :

  • première installation toute neuve du squelette ou de SPIP
  • mise à jour mineure ou majeure du squelette ou de SPIP
  • prérequis pour l’installation (hébergement, paramétrage PHP ...)

Veuillez respecter cette thématique et comme pour tous les autres forums appliquer les recommandations générales d’écriture des messages et de respect des autres contributeurs.


Commentaires

Logo de jf35
évolution de Sarka-SPIP ?
samedi 17 septembre 2016 à 09h56 - par  jf35

Bonjour,
Ce site n’est plus mis à jour depuis plus de 2 ans.
Qu’en est-il du projet Sarka-SPIP ? Est-il abandonné ?
J’ai fait évoluer (avec difficulté) un site de la version 3 à la 4 et l’apport de celle-ci est indéniable pour les internautes quelque soit le type d’écran qu’ils utilisent.
Ce serait donc dommage de s’arrêter là.
En tous cas, un grand merci aux développeurs.

Logo de jf35
lundi 19 septembre 2016 à 15h58 - par  AJCF RV

Que voilà une bonne question que je n’avais pas encore eu le courage de poser.

Sarka parait bien mort depuis un bon moment : Eric est seul, plus d’équipe, plus personne sur le forum.
La version 4 est réservée aux initiés qui peuvent entrer dans le code car pas de mode d’emploi, pas d’aidants sur le forum. Ce n’est pas mon cas et la grande qualité de Sarka 3 était d’être utilisable sans toucher le code, en paramétrant tout depuis l’interface, très bien faite.

De plus, moi je trouve la version 4 moche sur ordi et tablette. La version 3 va très bien sur ordi et tablette et quand on fait un vrai site avec des textes à lire, ce n’est pas pour les lire sur un petit écran de téléphone en priorité.

J’ai écrit à Eric le 10 juin, sans réponse, je vous mets l’essentiel de mon message :


J’utilise Sarka-SPIP depuis 2010 : tout d’abord merci parce que grâce à toi (et l’aide du forum, des thèmes) j’ai pu réaliser plusieurs sites pour des associations sans le sou, avec des compétences en informatique faibles. 3 sont encore en ligne.

N’étant pas experte et n’ayant plus le temps ni l’envie, j’avoue en être restée à SPIP 2 et sarka 3.0.8 ! Surtout, j’ai un site qui utilise SPIP-Listes, pas bien maintenu, et je n’ai pas voulu casser la newsletter que j’utilise et qui marche à peu près. Pb d’un plugin réalisé et maintenu par une seule personne...

Mais il y a un temps pour tout : il me faut quand même passer à SPIP 3 et faire une newsletter différente.

De plus, cette version Sarka 3.4.6 est ancienne, pas responsive.

J’ai regardé Sarka 4 : déjà je n’aime pas son look sur ordi. Et j’ai encore plus peur car il évolue et personne ne peut aider.

Mais je ne sais pas quoi faire. La solution d’attente est de mettre à jour en SPIP 3 et Sarka 3.4.6, en espérant ne pas avoir de pbs. Mais après ?

Je sais que les meilleures choses ont une fin, mais on espère que ce sera le plus tard possible.
Je souhaite continuer avec Sarka, si ce n’est pas possible, je le regretterais.

En te remerciant encore de m’avoir permis de réaliser des sites simplement mais de qualité,


Je n’ai pas eu de réponse et je m’interroge sérieusement sur l’avenir de Sarka SPIP. Certains passent ou sont déjà passés à WordPress ou autres, Je n’ai pas très envie, et je pleure !

Logo de pgiron
Nouvelle version 3.4.6
samedi 12 décembre 2015 à 15h05 - par  pgiron

Elle vient de sortir sans doute il y a très peu, mais... pourquoi en cachette ? :-(

Logo de MClerc
Documentation Sarka-SPIP 4.5.2 ?
vendredi 6 novembre 2015 à 12h01 - par  MClerc

Sur le site http://plugins.spip.net/sarkaspipr.html, qui présente Sarka-SPIP 4.5.2, donné comme stable, il y a un lien Documentation. Mais quand on clique dessus, on tombe sur une page indiquant :

« Cette rubrique contient la documentaion officielle de Sarka-SPIP. Elle décrit toujours la dernière lignée stable, soit aujourd’hui la 3.0. »

D’où ma question : quelle est la bonne adresse pour trouver la documentation de la version 4.5.2 ?

Merci d’avance, car sans doc, je galère énormément !

Logo de MClerc
dimanche 20 mars 2016 à 16h59 - par  pgiron

Une question bête : comment simplement changer les couleurs de la titraille H1 à H6 ? Mystère... et aucune indications sauf erreurs de ma part.

Logo de pgiron
samedi 12 mars 2016 à 23h21 - par  pgiron

Je reviens sur ce que j’ai dis et je retire mes critiques. Certes la doc est minimale, mais avec un pu d’intuition on arrive à s’en sortir. le résultat est pas mal du tout !
Je bute quand même sur la charte graphique que je n’arrive pas trop à faire évoluer d’autant plus que la page Apparence de a configuration n’est pas très explicite ! Et puis dans la configuration des menus avec le plugin éponyme, j’aurai aimé introduire un saut de ligne, mais bon...

Logo de pgiron
vendredi 22 janvier 2016 à 07h47 - par  pgiron

Dans "Configurer Sarka-SPIP"
- La page "Agenda" est vide.
- Le "Pied de page" est vraiment minimal.
- Le "Layout" n’existe plus mais ça peut se comprendre si on veut être responsive.
- L’outil "Apparence" est intéressant mais il manque l’équivalent de "Style" qui permet non pas de programmer les couleurs mais de se rendre compte quelle partie de la page web on change.
En tout cas, bon courage... :-)

Logo de pgiron
vendredi 22 janvier 2016 à 07h39 - par  pgiron

Ah, dans ce cas je suis désolé, je te prie de m’excuser mais la documentation pêche et je ne vois pas l’équivalent de "Styles" dans la configuration. Ce n’est plus utile ?
Je me trompe ou bien le plugin Agenda est de retour ?

Site web : Essai de site 4.5.3
Logo de pgiron
jeudi 21 janvier 2016 à 15h48 - par  _Eric_

Hello,

Je ne comprends pas le commentaire mort née.
Cette version a fait l’objet d’un ajout il y a quelques mois pour commencer à paramétrer les couleurs ce qui comble un manque important par rapport à la 3.

Qu’est ce qui exactement cloche sur cette version ?

Logo de _Eric_
mercredi 20 janvier 2016 à 17h33 - par  pgiron

Version 4.5.2 : morte née. Dommage...

Logo de pgiron
samedi 12 décembre 2015 à 15h07 - par  pgiron

Euh... "qiuand on va" (il y a un "se" en trop...

Logo de pgiron
samedi 12 décembre 2015 à 15h06 - par  pgiron

En plus elle n’a pas l’air finalisée, quand on se va dans l’interface de configuration.

Logo de pgiron
samedi 12 décembre 2015 à 15h06 - par  pgiron

Je suis aussi (TRÈS) intéressé !

Logo de MClerc
Sarka-Spip Reloader 4.5.2.. Revenir à la version 3 ?
lundi 2 novembre 2015 à 11h00 - par  MClerc

Sous SPIP 3.0, quand j’ai cherché un plugin Sarka-SPIP, seule la version Reloaded 4.5.2 m’a été proposée. Comme elle était déclarée « stable », je l’ai installée.

Mais plusieurs choses ne sont pas utilisables ou ne sont pas documentées du tout (Agenda, par exemple), fonctionnent bizarrement (sous Zen Garden, les thèmes pour lesquels le xml déclare utilise id="SarkaSpip" ne s’affichent pas) ou sont bien moins conviviales qu’avant (modifier les styles, la mise en page).

Dois-je envisager de remplacer la 4.5.2 par une version 3 ? Et si oui, comment le faire proprement ?

Logo de Joe76000
MàJ impossible de Sarka-SPIP 3.2.36 vers 3.4.5
mercredi 28 octobre 2015 à 20h25 - par  Joe76000

Bonjour,

Je viens de faire la mise à jour réussie (avec spip_loader.php) de mon site Linux Rouen Normandie (hébergé chez OVH) de SPIP 3.0.17 vers 3.0.20.

Mais impossible de faire la mise à jour de Sarka-SPIP 3.2.36 (squelette installé à l’origine il y a un an) vers 3.4.5. C’était déjà le cas sous la précédente version de SPIP.

Je donne le détail de mon problème :
- Sur mon site en ligne, dans l’Espace privée -> Configuration -> Gestion des plugins -> Tous les plugins ont bien été mises à jour.
- Dans la Liste des plugins actifs, Sarka-SPIP 3.2.36 - stable est bien listé OK mais sans la roue de mise à jour.
- Si je vais dans Ajouter des plugins, j’entre sarka-spip et je clique sur Rechercher, j’obtiens une liste où je trouve Sarka-SPIP 3.4.5 - test - déjà installé ! ? Ce qui n’est pas le cas ! J’avais aussi compris que cette version était stable et pas test !
- De plus, je trouve aussi dans cette liste Sarka-SPIP Reloaded 4.5.2 - stable, qui m’intéresserait, mais avant je voudrais passer par la Sarka-SPIP 3.4.5 pour m’assurer que tout fonctionne correctement.
- Ultime vérification : Squelette -> Configurer Sarka-SPIP -> j’obtiens
Sarka-SPIP 3.2.36 [77717]
SPIP 3.0.20 [22255]
PHP 5.6.6
et pas Sarka-SPIP 3.4.5 ! ?
Je suis complètement perdu par ces informations contradictoires.

Je n’ai n’ai qu’un an d’expérience des CMS et de SPIP / Sarka-SPIP en particulier.
Si j’ai mal fait quelque chose et/ou des idées sur comment résoudre ce problème...
Merci. Librement,
Joseph

Logo de Joe76000
samedi 31 octobre 2015 à 16h36 - par  Joe76000

Bon, je pense avoir résolu mon problème en décidant de passer, à regret - mais à l’impossible nul n’est tenu, de SPIP 3.0.20 à WP 4.3.1.
Les forums et documentations de WP, en français et en anglais, sont beaucoup plus dynamiques, fournis, complets et à jour que ceux de SPIP.
Le patriotisme a ses limites que je viens d’atteindre, mais au moins, je resterai avec un CMS open source, ce qui me console un peu.

- Market share yearly trends for Content Management Systems for Websites
- Usage of Content Management Systems for Websites
- Usage statistics and market share of SPIP for Websites

Librement,
Joseph

Logo de Joe76000
jeudi 29 octobre 2015 à 20h33 - par  Joe76000

Questions subsidiaires quand je lis que la branche 3.1 à 3.4.5 de Sarka-SPIP est utilisée dans 6.397 sites au 21 juin 2015 :
- Combien que pour la version 3.4.5 ?
- Est-il sans risque connu de migrer vers cette version qui est apparemment toujours en Test ?
- Alors que la version 4.5.2 est en Stable !

Pour un profane ou presque, il y a de quoi y perdre son latin.
Merci.

Logo de Joe76000
jeudi 29 octobre 2015 à 20h20 - par  Joe76000

Bon, j’ai beau lire et relire les explications du lien que j’indiquai dans mon précédent message, je ne comprends pas comment se fait l’installation manuelle d’une manière sure.

Comme déjà écrit, l’installation automatique ne se fait pas à cause d’une confusion de SPIP 3.0.20 (et aussi 3.0.17) qui mélange la version 3.2.36 effectivement installée avec la 3.4.5 supposée être installée de Sarka-SPIP. Il y a comme un bogue.

Je viens de revérifier et j’ai bien la 3.2.36 d’installée sur le serveur de OVH :
- /www/spip3/plugins/auto/sarkaspip/3.2.36
et pas un autre Sarka-SPIP.

Alors, je reviens au lien expliquant la mise à jour de Sarka-SPIP 3.2 vers 3.4+.
Remplacer votre squelette par la version Sarka-SPIP 3.4 ou ultérieure
Pour installer le nouveau squelette il suffit de suivre les procédures habituelles (pour les initiés !) :
1. "... soit en copiant manuellement par FTP le zip de la branche 3.4 ou ultérieure disponible à cet emplacement http://files.spip.org/spip-zone/sarkaspip_3x.zip ..."
Ben oui, et on le copie où exactement sur le serveur ?
Et en zippé ou en dézippé ?
Et que devient la 3.2.36 déjà installée ?

2. "... Si vous avez choisi une installation manuelle, installez donc ce plugin (Z-Core) en complément de la nouvelle version de Sarka-SPIP. Le zip du plugin Z-Core est disponible à cet emplacement : http://files.spip.org/spip-zone/z-core.zip ..."
Bon, ça c’est clair.
Et, je suppose qu’il faut le faire après Sarka-SPIP, pas avant.

Pour l’instant, j’arrête où j’en suis, n’ayant aucune envie de planter mon site, mais qui ne peut évoluer.
Merci.

Logo de Joe76000
jeudi 29 octobre 2015 à 17h01 - par  Joe76000

Bon, je vais suivre la procédure de mise à jour manuelle de cet article :
- Migrer Sarka-SPIP de la branche 3.2 à 3.4 ou ultérieure
et voir ce que cela donne...

Logo de adhafera
Nouveaux thèmes installé ne s’affichent pas_resolu_
vendredi 12 juin 2015 à 09h53 - par  adhafera

Bonjour,

Je viens de me mettre à spip 3.0.19 et j’aimerai installer des thèmes via sarka.
J’ai donc installé, entre autre, les plugins sarka-spip 3.4.5 et zen-garden 2.6.2.
J’ai ensuite téléchargé l’archive des thèmes disponible sur ce site, et j’ai envoyé chaque dossier de thème dans le dossier /themes/ à la racine de spip via le ftp. Ce dossier à les droits 755.

Lorsque je vais dans le menu Squelettes/Themes, aucun thème ne s’affiche.
Aurais-je loupé une étape ?
De plus, sur cette page, le pied de page ne s’affiche pas. Est-ce un bug ?

Désolé pour ces questions de noob, mais lorsqu’on débute, ce n’est pas toujours évident à prendre en main :/
Merci d’avance,
Adhafera

Logo de adhafera
mercredi 13 janvier 2016 à 09h11 - par  spiritualcreat

Refaire une installation complète de quoi ? De tout le site ??

Logo de spiritualcreat
mercredi 13 janvier 2016 à 08h48 - par  adhafera

Bonjour,

Oui, la solution a été de refaire une installation complète. Plus de problème après...

Logo de adhafera
mercredi 13 janvier 2016 à 08h04 - par  spiritualcreat

Bonjour, j’ai exactement le même problème, mais après avoir fait la mise à jour sur Spip 3.1.0 et après avoir installé Sarka-SPIP Reloaded 4.5.3.
J’ai bien installé tous les dossier de thème sarkaspip dans le dossier "themes" sans accens, et il n’affiche pas les thèmes dans le menu Squelettes/Themes

Avez vous trouvé la solution ?

Merci

Logo de spiritualcreat
jeudi 23 juillet 2015 à 18h50 - par  KaSar

Et "themes" dans plugins ?

Logo de KaSar
samedi 13 juin 2015 à 23h39 - par  adhafera

Bonsoir,

Merci pour la réponse.
Mais je ne pense pas que c’est le problème : j’ai bien nommé le dossier comme il le faut.

Document joint :  spip_theme.png
Logo de adhafera
samedi 13 juin 2015 à 22h33 - par  pierre

Bonjour.

Vérifie si tu n’as pas mis un accent grave au répertoire themes (thèmes alors que c’est themes qu’il faut avoir).

Si c’est le cas, tu ne vois pas le répertoire themes dans l’espace privé.

Bonne journée.

Pierre

Logo de LouisV
Les commentaires sous les articles n’apparaissent plus sous Sarka-SPIP
dimanche 7 juin 2015 à 12h24 - par  LouisV

Bonjour,

J’ai créé un site sous SPIP (3.0.19), pour le moment encore dans mon localhost.
J’ai créé des rubriques et quelques articles, et mis des commentaires sous certains.
J’installe alors Sarka-SPIP (3.4.5).
À ce moment les commentaires n’apparaissent plus dans le site public ; on ne peut même plus en ajouter.
Pourtant les commentaires ne sont pas disparus et sont visibles depuis le site privé.

Je précise que même sans aucune configuration de Sarka-SPIP les commentaires ne sont déjà plus visibles.
Je n’ai pas non plus de mise en forme faite autrement qu’avec les raccourcis SPIP.

Je suis sous Ubuntu 14.04

Voyez-vous où j’ai pu faire une erreur ?

D’avance merci pour votre aide.

Logo de KaSar
SarkaSPIP v4 (Responsive)
vendredi 8 mai 2015 à 16h37 - par  KaSar

Bonjour,

Je cherchais une discussion dédiée à SarkaSPIP v4, le squelette "Responsive" mais je ne trouve pas…

Existe-t-elle ?

Merci.

Logo de KaSar
dimanche 11 octobre 2015 à 14h31 - par  KaSar

Bonjour à tous,

Je me bat pour supprimer le "Fil d’Ariane" qui se trouve sous le bandeau de tête. Pas moyen de trouver dans quel fichier supprimer cette boucle :(

Si quelqu’un était passé par là… merci d’avance ;)

Logo de KaSar
mardi 29 septembre 2015 à 17h14 - par  pgiron

Hello,
Pour ma part je teste aussi la version 4.5 mais je me pose des questions : quid de l’agenda qui ne s’affiche pas en forme de mini-calendrier sur la page d’accueil et du layout . Celui-ci existe-t-il encore ?

Site web : Mon site de tests
Logo de pgiron
jeudi 23 juillet 2015 à 18h31 - par  KaSar

Hélas non :( et c’est vraiment bien dommage.

Si je trouve quelque chose, je vous en ferais part ;)

Logo de KaSar
jeudi 23 juillet 2015 à 17h59 - par  PhilOGM

Bonjour,

je cherche aussi pour la mise en place d’un site des infos sur le Sarka-Spip relaoded 4.5.

C’est le côté "responsive" qui nous intéresse.

Je ne trouve rien comme discussion sur ce squelette "sarka" bien qu’il soit dirait-on en "stable".
Sa gestion semble bien différente, au moins au niveau css et position des éléments (colonnes, noisettes,...) que pour Sarka 3.4 par exemple.

Avez-vous eu des réponses où trouver des infos ?

Merci !

Logo de Blaise
Au secours ! L’affichage de ma partie privée totalement inutilisable
mercredi 4 mars 2015 à 10h24 - par  Blaise

Bonjour,

Ce forum n’est peut-être pas le bon endroit pour ce qu’il m’arrive,
mais ne trouvant pas de réponse dans les différents forums SPIP
je m’adresse à vous qui m’avait déjà secouru.

Comme vous pourrez le constater sur les prises d’écran, mon affichage de la partie privée est totalement déréglée et quasi inutilisable.
N’ayant pas encore terminé la configuration de mon site je n’ai pas encore fait la sauvegarde, donc je n’ai rien à restaurer.

Merci pour votre aide

Blaise

Sarka-SPIP 3.4.5 [87153]
SPIP 3.0.17 [21515]
PHP 5.2.17

Document joint :  capture1.jpg
Logo de _Michel_
Comment installer SPIP dans un dossier de la racine du site
vendredi 20 février 2015 à 09h55 - par  _Michel_

Bonjour,
j’ai un site en production (SPIP 2.1.19 et Sarka 3.1.0) installé directement à la racine du site.
J’ai tester la migration en SPIP 3.0.17 et Sarka 3.4.5 en créant un sous-domaine et en installant SPIP dans un dossier "test" de la racine du site de production.
La migration et les test s’étant bien passés j’ai reproduit mon site de production dans un autre sous-domaine installé dans un dossier "newsite" de la racine.
Les 3 sites ont chacun leur propre BD.
Peut-on rediriger le nom de domaine principal sur un site installé dans un dossier de la racine tout en gardant le même référencement pour les moteurs de recherche et l’affichage de l’URL du site principal dans le navigateur ?
J’ai trouvé quelques pistes en reconfigurant le .htaccess mais je ne suis pas arrivé à un fonctionnement correct et les post étaient assez anciens.
Si quelqu’un a une solution, merci d’avance.
A+, Michel

Logo de KaSar
Rangements du squelette et des plugins
vendredi 6 février 2015 à 10h45 - par  KaSar

Bonjour,

Je suis nouvel utilisateur de Sarka-SPIP.
A la page Installer le squelette Sarka-SPIP
je vois qu’il est signalé de placer les plugins directement à :

svn co svn ://zone.spip.org/spip-zone/_plugins_/cfg cfg


et le squelette à :

svn co svn ://zone.spip.org/spip-zone/_squelettes_/sarkaspip/stable_30 sarkaspip


J’avais lu, par ailleurs, sur Spip que les plugins de rangeaient à : racine/plugins/auto/… ainsi que le squelette.
Seuls, les fichiers issus de "squelettes-dist" et modifiés se plaçaient à : racine/squelettes/…
Qu’en est-il ? quelle est la bonne ou meilleure solution ?
Merci de m’aider à démarrer du bon pieds ;)

Logo de KaSar
vendredi 6 février 2015 à 17h58 - par  KaSar

Merci beaucoup de m’avoir confirmé tout cela. J’avais des doutes maintenant je continue (en local).
Je cherche à maintenir le texte de ma première rubrique en page d’accueil au lieu d’avoir la liste des "Articles les plus récents".
Je pense trouver cela dans les mots-clés mais c’est un autre sujet…

Logo de KaSar
vendredi 6 février 2015 à 15h39 - par  hdeb

Pardon, j’ai effacé ma phrase :

Créer un répertoire /plugins/auto à la racine destinés à recevoir les plugins chargés depuis la configuration de Spip.

Henri

Logo de hdeb
vendredi 6 février 2015 à 14h32 - par  KaSar

Donc dans "plugins" ou "plugins/auto" ?

Logo de KaSar
vendredi 6 février 2015 à 14h26 - par  hdeb

Bonjour,

Ne touchez à rien ... j’ai des souvenirs douloureux de mes débuts. Chaque mise à jour viendra surcharger les fichiers sauf ceux qui sont prévus pour recevoir vos modifs. Donc, aucun intérêt à les bricoler.

Le squelette Sarkaspip est distribué sous forme de plugin.

Pour télécharger le fichier zip depuis la page sarka-spip.net, copiez l’URL de Sarka-SPIP 3.4 ou Sarka-SPIP 3.2 selon ce que vous voulez.

Le plus rapide est de passer par Gestion des plugins (menu configuration) > Ajoutez des plugins > Plugins et collez l’URL dans la ligne "URL de l’archive". etc.

Ensuite vous pourrez passer à la configuration de Sarkaspip qui sera mémorisée.

Vos personnalisation par rapport à ce que propose Sarkaspip une fois configuré sont à mettre dans un dossier /squelettes à créer à la racine du site. En particulier, vos modifs de css sont à écrire dans un fichier "perso.css.html" à placer dans un sous-répertoire /squelettes/css.

Cdt.
Henri

Logo de ZappaPY
SarkaSpip , Où en es-t-on ?
jeudi 22 janvier 2015 à 14h06 - par  ZappaPY

Milles excuses pour le doublon , je n’ai pas posté où il le faut au premier jet
Je reprends contact avec le monde de SPIP relativement régulièrement , mais là je suis pommé . Qui pourrait répondre aux trois questions suivantes s’il vous plait :
1) Quelle est la dernière version stable de SarkaSpip ?
2) Qu’est-ce que SarkaSpip V4 ?
3) Pourquoi les informations concernant la "V4" ou "SPIPr" sont-elles dissociées de Spip-contrib , SarkaSpip , etc

Je voudrais mettre à jour d’anciens sites depuis longtemps sous SarkaSpip et d’autres , plus récents . Merci d’avance pour vos réponses .

Logo de ZappaPY
jeudi 23 juillet 2015 à 19h28 - par  KaSar

Bonsoir,

J’arrive peut-être trop tard…

J’ai installé directement le plugin Sarka-SPIP Reloaded 4.5.1 - stable sans SPIP v3.0 ni SPIPr v1 proposés sur la page http://spipr.nursit.com/telecharger et ça marche mais ne devrais-je pas rajouter ces deux squelettes ?

Merci ;)

Logo de KaSar
vendredi 3 avril 2015 à 17h54 - par  _Christophe_

C’est un thème Zen-Garden... il s’affiche dans les plugins quand on le sélectionne, les autres étant aussi présents mais classés en inactifs.

Dans les inactifs j’ai ainsi Amelia, Beige, Cerulean, Cosmo etc etc.

Je n’ai pas trafiqué mes captures écran...

Logo de _Christophe_
vendredi 3 avril 2015 à 10h12 - par  Valin (Patrick)

Bon je ne comprnds pas alors, de plus il semblerait que le plugin SPACELAB n’existe pas...

Logo de Valin (Patrick)
vendredi 3 avril 2015 à 09h49 - par  _Christophe_

La réponse se trouve dans la doc SPIPr (le lien fourni hier) et dans les captures écran de mes plugins : ZenGarden et SpaceLab.

Logo de _Christophe_
vendredi 3 avril 2015 à 09h46 - par  Valin (Patrick)

Quand tu écris choisir un thème, tu parles de quoi ? un de SPIPR ou un thème "couleur" ?

Logo de Valin (Patrick)
jeudi 2 avril 2015 à 19h32 - par  _Christophe_

Pour le privé, désolé mais en ce moment ça ne va pas être possible (surchauffe de boulot).

Concernant SPIPr, tout est détaillé ICI.

Concernant le protocole, de mémoire (et vite fait) :

- désactiver Sarka-SPIP 3,
- vider tmp et compagnie,
- installer SPIPr comme indiqué au dessus,
- choisir un thème,
- installer Sarka-SPIP 4...

Pour les plugins voici une capture écran et une deuxième.

Tous ne sont pas obligatoires bien sûr.

a+

Logo de _Christophe_
jeudi 2 avril 2015 à 18h52 - par  Valin (Patrick)

Merci Christophe. Est-il possible de se contacter en privé ?
Sinon tu as activté quoi de SPIPR ? je ne comprends pas.
Peux tu me faire une copie d’écran des plugins actifs ? et du protocle suivi pour muter ?
En fait j’ai 3 site en SPIP 3.0.17 [21515] | Sarka-SPIP 3.4.5 [84607] et je voudrais avoir migrer. et me familiariser avec la nouvelle apparence car j’ai un nouveau site à réaliser....

Site 1 , site 2 et site3

Logo de Valin (Patrick)
jeudi 2 avril 2015 à 16h32 - par  _Christophe_

C’est exactement ce que j’ai fait.

Tu peux consulter le résultat ICI

Bien entendu je n’ai plus la version d’origine en spip 2 et SarkaSPIP 3, mais la capture écran ci-jointe te donnera une idée en ce qui concerne la page d’accueil. Il s’agissait d’une personnalisation "en noir" suite aux attentats, sinon les couleurs étaient un peu plus variées...

J’ai perdu certaines fonctions au passage (définitivement ou momentanément), par exemple le nuage de mots clés, mais pour l’instant ça me va bien.

Logo de _Christophe_
jeudi 2 avril 2015 à 16h22 - par  Valin (Patrick)

il faut donc installer SPIP 3, puis SPIPR et aussi SARKA4 RELOADED ?

Logo de Valin (Patrick)
jeudi 2 avril 2015 à 15h54 - par  _Christophe_

Tu trouveras toutes les infos sur SPIPr ici.

Il est effectivement "responsive".

Il est utilisable avec 3 squelettes, du plus simple au plus complet, ce dernier correspondant à SarkaSPIP 4 reloaded.

Si tu souhaites conserver une bonne partie des fonctionnalités de ton site actuel sous Sarkaspip3, alors la combinaison SPIPr / Sarkaspip 4 me paraît la meilleure formule.

Logo de _Christophe_
jeudi 2 avril 2015 à 15h08 - par  Valin (Patrick)

Une question bête mais à quoi sers SPIPR ? Il est réponsif aussi non ?
Sinon pour le moment si on n’a pas de connaissance pointu dans le domaine, il ne vaut mieux pas installer SARKASPIP 4 reloaded...?
Sinon on installe soit SPIPR soit SARKASPIP 4 mais les deux avec un SPIP3 ? C’est bien ca ? Donc SPIPR n’a rien à vour avec la nouvelle version de SARKA

Logo de Valin (Patrick)
jeudi 2 avril 2015 à 14h48 - par  Valin (Patrick)

Une question bête mais à quoi sers SPIPR ? Il est réponsif aussi non ?
Sinon pour le moment si on n’a pas de connaissance pointu dans le domaine, il ne vaut mieux pas installer SARKASPIP 4 reloaded...?

Logo de Valin (Patrick)
jeudi 2 avril 2015 à 09h54 - par  nolan80

Salut Christophe

Personnellement, je préfère la version précédente. Il reste sécurisant. Mais c’est à chacun d’en juger.

www.fax-mailing.pro

Site web : www.fax-mailing.pro
Logo de nolan80
mercredi 1er avril 2015 à 21h06 - par  _Christophe_

"A." je ne comprends pas la question... c’est exactement ce que j’ai fait, déployer Sarkaspip 4 reloaded par dessus une version 3.

D’abord en local, puis directement sur mon site de "prod", en me servant de certaines explications de wiki.dane par exemple en déplaçant tout dans un sous répertoire, histoire de pouvoir récupérer certaines choses.

Ce n’est pas plus compliqué que de partir d’un spip en dist et d’installer Sarkaspip. La version 4 est beaucoup moins paramétrable par contre au niveau visuel, d’où ma suggestion de tester en local avant...

Logo de _Christophe_
mercredi 1er avril 2015 à 11h50 - par  Valin (Patrick)

Ahhhhhhhhhhhhh merci on avance... Par contre quid de SPIPR ? Faut-il l’installer ?

Logo de Valin (Patrick)
mardi 31 mars 2015 à 18h55 - par  A. LE GALL

La mise à jour Spip 3, pas de problème. Le problème c’est de déployer Sarka (wiki.dane parle de scola pas de sarka.
Merci pour le tuyau quand même.

Logo de A. LE GALL
mardi 31 mars 2015 à 14h34 - par  _Christophe_

Bonjour,
Je propose la démarche suivante :
- faire une installation en local (easyPHP)
- rapatrier une sauvegarde afin de faire tourner le site actuel en local
- mettre à jour en local SPIP et SarkaSpip 4 reloaded
- configurer, choisir un thème
et si ça convient, faire la même chose sur le site de production.
On trouve de la doc au sujet des mises à jour majeures, dont il est possible de s’inspirer, par exemple :
http://wiki.dane.ac-versailles.fr/index.php?title=Mise_a_jour_SPIP3
A+
Christophe

Logo de _Christophe_
mardi 31 mars 2015 à 11h23 - par  A. LE GALL

Pour moi, le problème où cela coince a déjà été signalé : comment réussir un passage relativement fluide de sarkaspip 3.2 à 3.3 ou évidemment 3.4… et de là pourquoi pas sauter aussi en Spipr et ce qui va avec !
Cordialement

Logo de A. LE GALL
mardi 31 mars 2015 à 09h47 - par  _Eric_

Hello,

Configurer un site c’est parfois un peu vaste. Le mieux serait de poser des questions précises car je n’ai pas développé aujourd’hui de documentation sur le sujet.

Logo de _Eric_
mardi 31 mars 2015 à 08h08 - par  pgiron

Moi-même suis coincé et en plus pris par moult autres affaires.... je suis preneur moi aussi.

Logo de pgiron
mardi 31 mars 2015 à 07h55 - par  A. LE GALL

La même charité m’intéresserait pour l’évolution du site catholique :
http://stfrancoisdesodons.catholique.fr/

Merci !

Logo de A. LE GALL
lundi 30 mars 2015 à 17h24 - par  Valin (Patrick)

Y-a-t-il une âme charitable qui veut bien me guider pour configurer mon site en SPIPR et SARKA 4...Merci

Logo de Valin (Patrick)
samedi 28 mars 2015 à 09h58 - par  Valin (Patrick)

Bonjour à tout le monde ici !
j’ai installé SPIPR et SARKASPIP4 reloaded. Par contre y a -t-il une façon de recuperer un site sur sarka 3.4 et spip 3 ? une mise à jour à faire ?
Sinon comment paraméter ce nouveau joli bolide ?
y a qq1 qui peut me guider ?

Logo de Valin (Patrick)
lundi 16 mars 2015 à 12h16 - par  hdeb

Bonjour,

Sarkaspip-4 et Spipr ... très bien !

Je suis très satisfait du site de publication que j’ai mis en place avec eux dans le but d’utiliser le côté responsive.

Je m’occupe d’un autre site en Spip 2 qui a plusieurs années d’existence (donc beaucoup d’articles) et avant de passer en Spip3 ou en Spipr, je voudrais savoir quel devenir ont les branches Spipr et Sarkaspip-4.

Merci.
Henri

Logo de hdeb
jeudi 5 mars 2015 à 17h56 - par  _Christophe_

Hello,
Alors pour Sarka, oui il faut le télécharger à part ... et comment dire... je ne me souviens plus où je l’ai trouvé pour le moment (oups).
Mais j’envoie illico le zip à qui le veut (*). C’est une version 4.4.16 "en test".
Concernant la base, elle est mise à jour automatiquement par la nouvelle version de SPIP, et ça n’a posé aucun problème chez moi, tant en local que sur mon site de "prod".
(*) il suffit par exemple de cliquer sur mon pseudo ici pour trouver un lien vers mon site et m’envoyer un message.
a+

Logo de _Christophe_
jeudi 5 mars 2015 à 17h52 - par  ZappaPY

Je suis aussi dans ce cas , mais je temporise encore ...

Et bien bon courage amirale !

Logo de ZappaPY
jeudi 5 mars 2015 à 17h19 - par  AJCF RV

en fait, les 2 mon général !

Mes 5 sites existants devront bien évoluer.

Logo de AJCF RV
jeudi 5 mars 2015 à 17h10 - par  ZappaPY

Si je me souviens bien , le problème principal est de faire lire une base de données de SPIP2 par SPIP3 . Il va falloir que je m’intéresse sérieusement au problème mais là , je manque un peu de temps ...

Faire un site à partir de rien sous SPIP3 et Sarka n’est pas la difficulté vu de mon côté , le problème est bien l’évolution des vieux sites ... C’est bien ce que tu veux AJCF RV ?

Logo de ZappaPY
jeudi 5 mars 2015 à 16h29 - par  AJCF RV

Bonjour à tous

Comme Christophe, je suis restée à SPIP 2.1.26 [21262] | Sarka-SPIP 3.0.8 [54368], par manque de temps, parce que j’ai fait 5 sites (merci SPIP, merci Eric !) qui fonctionnent bien je ne suis pas spécialiste.
Mais il faudra bien un jour, alors comme Christophe, je suis tentée par le grand saut plutôt que de passer à SPIP 3 et au Sarka SPIP 3 correspondant.

Je vais donc essayer sur un site de test : je suis allée sur http://spipr.nursit.com/, j’ai téléchargé comme expliqué la dernière version de SPIP 3, puis SPIPr V1 mais je n’y trouve pas Sarka SPIP 4 :
faut-il le télécharger à part et le rajouter ?

Logo de AJCF RV
mardi 3 mars 2015 à 14h36 - par  _Christophe_

Bonjour à tous,

Utilisateur Sarka-Spip depuis ... un certain temps (2008 ?) et depuis un certain temps bloqué en version Sarka-Spip 3.1 avec la dernière version de spip 2, après quelques tests en local, j’ai fait dimanche le grand saut avec la 4.4.16 et SpipR.

J’avais envie de "responsive"... et de conserver certaines choses auxquelles j’étais habitué. Du coup j’ai perdu (momentanément ?) certaines fonctions ou personnalisations, j’ai vu passer quelques messages d’erreur au début (en lançant une recherche dans la partie publique), mais sans changer d’hébergement la différence de réactivité est saisissante (cela vient-il de SPIP 3 ? de SarkaSpip V4 qui m’a l’air un peu simplifié ? des 2 ?) et je suis ravi du rendu notamment sur mobile.

On verra plus tard pour les personnalisations, j’ai un thème qui me va bien, et tout roule.

Christophe

Logo de _Christophe_
samedi 7 février 2015 à 12h08 - par  ZappaPY

Merci hdeb ,

J’essaierai ça dans 2 ou 3 semaines sur un vieux SarkaSpip ...

Logo de ZappaPY
samedi 7 février 2015 à 10h20 - par  hdeb

Bonjour,

Quelques mots sur mes premiers pas avec Sarkaspip V4 avec Spipr.

  • Sarkaspip V4 se substitue aux squelettes Spipr-doc, Spipr-dist, Spipr-blog.
  • Quand on regarde la liste des plugins, il n’ y a pas de plugin Spipr.
  • Mais 3 plugins Spipr-doc, Spipr-dist, Spipr-blog. Il faut les désactiver et activer Sarkaspip V4.
  • C’est là qu’on se pose la question que devient Spipr qui n’est pas dans la liste des plugins ?
  • Si ça marche, c’est bon ...
  • Et voici le bon vieux Sarkaspip avec ses couleurs typiques ! On n’est pas dépaysé et on sait où on est !
  • Pour inverser Aside (navigation) et Extra (more stuff) donc passer de Layout9 à Layout10, la page Layout de la config de Sarkaspip a disparu.
  • De même, dans la page colonnes, il n’est plus possible d’attribuer une colonne aux noisettes.

Voici où j’en suis.
Henri

Logo de hdeb
jeudi 5 février 2015 à 16h32 - par  ZappaPY

@pgiron Effectivement , comme indiqué dans ma première intervention en haut de cette page la version 4 est sur nursit mais je pense qu’Éric parle de la version 3 : Sarka-SPIP
3.4.5 - test
et non de la version 4 : Sarka-SPIP Reloaded 4.4.16 - test que l’on voit sur http://spipr.nursit.com/ qui propose un plus grand bouleversement il me semble .

@_Eric_ Merci de ta réponse , peu sont mieux placés pour nous instruire à ce sujet . Je me permets ici de te féliciter d’avoir continué le projet après les décès et défections qui se sont succédés dans l’histoire de SarkaSpip . J’ai commencé à installer un squelette Ahuntsic ( plus maintenu à présent il me semble ) et un SarkaSpip en 2007 et j’ai apprécié de pouvoir publier sur le web grâce à ce beau CMS qu’est Spip .

Logo de ZappaPY
jeudi 5 février 2015 à 14h23 - par  pgiron

Je suppose qu’il s’agit de SarkaSPIP v4 que l’on trouve ici : http://spipr.nursit.com/

Logo de pgiron
jeudi 5 février 2015 à 14h06 - par  pgiron

Ah voilà une réaction intéressante :-)
Mais elle est donnée "en test"... Et moi j’ai pas mal de sites en 3.2... Mes questions sont : comment je fais, avec quelles précautions, quels points d’attention, etc...

Logo de pgiron
jeudi 5 février 2015 à 13h49 - par  _Eric_

Hello,

Surtout pas la version 3.2 dont j’ai abandonné le développement !
La dernière version de Sarka-SPIP dans la lignée 3 est la version 3.4 qui a déjà fait une première évolution en passant sous Z.

Je reviendrais plus tard pour expliquer plus en détails où on en est sur Sarka-SPIP.

A bientôt.

Logo de _Eric_
jeudi 5 février 2015 à 11h50 - par  pgiron

Bon, on peut peut-être déjà améliorer la version actuelle 3.2.26... Le problème c’est que mes notions de PHP sont lointaines.
Sinon j’ai deux demandes pressantes... ;-)

Logo de pgiron
mercredi 4 février 2015 à 16h53 - par  ZappaPY

Bien sûr qu’on sent une fin de quelque chose , d’une période . C’est clair .

Les langages du web évoluent , les sites évoluent et il n’est pas évident de maintenir un CMS , comme tout programme sur la durée . Mais remarquons que SarkaSpip est utilisé dans des milliers de sites et les raisons qui ont fait son succès sont encore là :
Des fonctionnalités bien assemblées et servies dans un squelette facilement configurable . Dans les sites que j’ai eu l’honneur de déployer , j’ai utilisé d’autres squelettes mais SarkaSpip n’a pas beaucoup d’équivalents . Je n’ai trouvé que Escal qui représente un peu le même type de concept puisque Zpip est entré aussi dans la mutation ...

À nous , utilisateurs de mettre la main à la pâte ! En tant qu’utilisateur de logiciels libres quasi exclusivement depuis dix ans , j’ai imaginé que j’apporterai un jour une modeste contribution . Même si je n’en ai pas le niveau , il faut y songer quand on utilise un outil ouvert , il faut essayer de voir comment on peut faire avancer le schmilblick .

Facile à dire , Toujours est-il que tout-à-lheure j’ai essayé d’installer la base dun site sous SarkaSpip 3.02 avec V3.5 ou sarkaV4 , ça n’a rien donné . J’avais oublié que les BDD anciennes ne sont plus gérées à présent ... Faut que je me replonge dans les anciennes docs .

Je suis encore loin du compte pour contribuer à moins que ce ne soit au forum :)

Logo de ZappaPY
mercredi 4 février 2015 à 15h58 - par  pgiron

Pas de doc, liens introuvables simplement... Sarka-SPIP entre-t-il en agonie avant la fin ? Question légitime !

Logo de pgiron
mercredi 4 février 2015 à 13h04 - par  ZappaPY

Merci de ta réponse hdeb (es-tu sous debian avec un tel pseudo , moi , c’est le cas !)

On peut accéder à la V4 de notre CMS préféré en demandant , sur "ajouter des plugins" , en optant pour "tous les états" , on se voit proposer , à cette date :

Sarka-SPIP Reloaded 4.4.16 - test

Le problème est que la doc manque , ou alors je ne sais où la trouver , pour passer d’un spip sous sarka V3 à V4 . Ce que l’on peut voir en ligne sur l’exemple donné a l’air très différent . Il faudrait faire un essai avec une base de données d’un site sous V3 pour voir la différence ...

On a l’impression qu’avec la version 4 , SarkaSpip n’est plus dans la continuité de ce que l’on connaissait ...Je me méfierai avant de faire le grand saut ...

Tout ça est bein vague , je sais mais j’ai bien du mal à y voir plus clair ...

Logo de ZappaPY
mercredi 4 février 2015 à 10h23 - par  hdeb

Bonjour,

J’ai à peu près les mêmes questions.

J’ai téléchargé sarkaspip-v4 en décembre dernier et sauf mémoire défaillante, je pense que c’était depuis la page Téléchargement de Spipr. Il ne s’y trouve plus.

Après un essai pas très concluant, j’ai repris le collier à l’occasion d’un nouveau site. Comme ça je suis dégagé des idées préconçues quant au rendu qui est assez frappant par rapport à ce qu’on publiait auparavant.

Je vais maintenant intégrer sarkaspip après essai du squelette doc..

Sarkaspip-v4 est sur spip-contrib : ICI

Bonne journée.
Henri

Logo de CdChar
Temps de réponse très mauvais, erreur de serveur
jeudi 17 juillet 2014 à 10h54 - par  CdChar

Bonjour,

Il y a quelques semaines j’ai migré 2 sites de la version
SPIP 2.1.10 [17657] | Sarka-SPIP 3.0.6 [48273]

à la version

SPIP 3.0.16 [21266] | Sarka-SPIP 3.4.1 [82905]

avec un bref passage par Sarka-SPIP 3.2

Tout m’a semblé se passer parfaitement bien, ce qui est toujours vrai pour un des sites qui m’avait servi de test . Je craignais manquer de ressources chez FREE avec les nouvelles versions.
Au départ les sites avaient les mêmes plugins installés, maintenant le site qui pose problème, http://afatcg.free.fr/, est de plus en plus léger mais n’échappe pas au message "Erreur 500 - Erreur interne du serveur" et si je réitère mes appels : "Nous avons détécté que votre adresse IP ouvrait trop de connexions vers notre serveur web.
Nous vous rappelons que ces pratiques sont strictement inutile et n’ont pour unique conséquence de ralentir les serveurs. Si vous désirez stocker temporairement des données, vous pouvez utiliser ce service : http://dl.free.fr que nous mettons à votre disposition.
"

J’ai désactivé, réactivé les plugins en vidant les caches "local" et "tmp" sans grand succès. De plus le comportement est aléatoire, il y a des moments où je peux naviguer du site public à l’environnement privé sans problème.

Dans les deux cas l’hébergeur est FREE, je sais, je connais déjà les commentaires.
je vais jeter un oeil sur le fichier htaccess, mais c’est le même depuis plusieurs années.

En partant du principe qu’il ne faut pas surcharger le serveur, quand je vois dans le log la ligne suivante :

Jul 16 02:38:55 66.249.64.2 (pid 32454) :Pub:ERREUR: Table 'afatcg.mots_articles' doesn't exist - SHOW CREATE TABLE `mots_articles`

répétée de façon consécutive 8 fois ( même heure, même pid), je me dis voilà une belle boucle qui ne mène à rien. d’autant plus inutile qu’il me semble que tous les noms de table commencent par "spip_", donc c’est "’afatcg.spip_mots_articles’ qui devrait être recherchée, elle n’existe pas plus.
Je trouve les mêmes problèmes pour :

’afatcg.spip_tickets’, ’afatcg.mots_syndic’

Le problème n’est probablement pas là car dans le site qui fonctionne je trouve les mêmes messages et également pour : ’imanelavie.notations’

J’ai recherché dans les sources de SPIP et des plugins la chaîne : "mots_articles", elle ne figure nulle part, peut-être dans une table de SPIP, la table "meta" contenant des données depuis 2004, passée depuis 10 ans au travers de toutes les migrations sans encombre.

Hier j’ai déactivé le plugin "crayons" sans effet, je viens de désactiver "Nuages".
Le problème vient sans doute plus d’un bridage de l’hébergeur, cependant si je pouvais alléger son travail en évitant des accès inutiles à la base ça serait bien.
Quand je recherche sur Internet, cette erreur, je tombe sur les logs de plein de sites (? sécurité) avec les même messages.

Merci pour toute suggestion.

Logo de CdChar
Sauvegarde de la configuration de SARKA SPIP Sarka-SPIP 3.4.1_resolu_
mercredi 16 juillet 2014 à 09h50 - par  CdChar

Bonjour,

Je viens d’installer Sarka-SPIP 3.4.1 [82905]

La sauvegarde de la configuration de SARKA ne se fait plus dans tmp/cfg mais dans
tmp/sarkaspip/config.
Le plugin mes_fichiers, ne sauvegarde pas cette arborescence.
Suffit-il de surcharger le fichier sarkaspip_pipelines.php en remplaçant la ligne :

$tmp_styles = defined(’_DIR_TMP’) ? _DIR_TMP.’cfg/’ : _DIR_RACINE.’tmp/cfg/’ ;
$tmp_styles = defined(’_DIR_TMP’) ? _DIR_TMP.’config/’ : _DIR_RACINE.’tmp/sarkaspip/config/’ ;
Je ne connais pas PHP j’ai juste essayé d’évaluer le code par similitude.

Ou y a-t-il un autre paramétrage permettant de la faire plus simplement.

Merci

Logo de CdChar
vendredi 18 juillet 2014 à 15h20 - par  CdChar

Merci Eric,
Tu peux prendre le pousse-café, ça marche.

Logo de CdChar
vendredi 18 juillet 2014 à 10h50 - par  _Eric_

Je viens de reprendre un café pour me réveiller.
Là ça devrait être enfin corrigé.
Version 3.4.3 dans 20 minutes elle sera disponible

Logo de _Eric_
vendredi 18 juillet 2014 à 10h21 - par  CdChar

Bonjour,

après avoir installé, vidé les caches, l’interface privée ne me propose que :
- config/mes_options.php (81.00 B)
- IMG/ (56.45 MB)
- squelettes/ (58.46 K)
- tmp/dump/afatcg_saveauto__afatcg_20140711_070710.sql.zip

Je ne vois pas :
tmp/sarkaspip/config qui contient bien des fichiers

En regardant le source de sarkaspip_pipelines.php, je vois :

$tmp_styles = defined('_DIR_TMP') ? _DIR_TMP.'cfg/': _DIR_RACINE.'tmp/sarkaspip/config/';

ceci est-il bien valide : _DIR_TMP.'cfg/':

Merci Eric

Logo de CdChar
vendredi 18 juillet 2014 à 08h33 - par  _Eric_

Hello,

Ca devrait être corrigé en 3.4.2.

Logo de _Eric_
mercredi 16 juillet 2014 à 11h08 - par  _Eric_

Hello,

Non tu as raison c’est un bug.
J’aurais faire évoluer le pipeline en même temps que le changement d’emplacement. Surtout ne touche à rien, je vais corriger cela ce soir et sortir une version corrigée.

Logo de Valin (Patrick)
Adaptation du squelette aux smartphones ?
jeudi 15 mai 2014 à 09h09 - par  Valin (Patrick)

Y-a-t-il une possibilité pour que le squelette puisse s’adapter à l’affichage sur un smartphone ?
Car c’est de plus en plus demandé par les utilisateurs de mes sites ?
J’ai bien essayé un plugin une fois (iSpip je crois...) mais pas convaincu par le resultat...

Logo de Valin (Patrick)
jeudi 23 juillet 2015 à 18h57 - par  KaSar

Essaye iTwX Mobile.

Je l’ai utilisé avant de passer à Sarka-SPIPr (v4.5.1)

C’est simple et ça peut dépanner en attendant la version 4…

Logo de KaSar
mardi 20 mai 2014 à 14h13 - par  Valin (Patrick)

Merci pour ta réponse. Mais c’est vrai que la demande d’une adaptation aux smartphones des sites est une demande récurrente des utilisateurs. En attendant la version 4 tant attendue, un plugin a ajouter pourrait faire l’affaire, mais je ne suis pas du tout calé pour en produire un....

Logo de Valin (Patrick)
lundi 19 mai 2014 à 15h54 - par  _Eric_

Oui bien sur, mais je ne peux pas te dire quand la version 4.0 sera au niveau de la 3.3 que je continue à améliorer.

Logo de _Eric_
lundi 19 mai 2014 à 10h49 - par  Valin (Patrick)

Une mise à jour de la version 3.3 à 4 sera possible ? Auquel cas, il me suffit de patienter.
En tous les cas merci pour ta réactivité et ton aide

Logo de Valin (Patrick)
samedi 17 mai 2014 à 09h43 - par  _Eric_

Patrick,

Dans la version 3.2 et 3.3 ce n’est pas prévu. Il faut utiliser la version 4.0 pour cela qui est opérationnelle mais qui ne propose pas encore le même niveau de configuration des précedentes versions.

Logo de _Laure_
Affichage logo documents joints
mardi 13 mai 2014 à 09h27 - par  _Laure_

Je viens de m’apercevoir que les logos des documents ne s’affichent plus.
Exemple : http://www.aplv-languesmodernes.org/spip.php?article5500
Après essais et retours en arrière je peux dire que ça date du passage de 3.2 à 3.3.46 (3.3.49 n’y change rien). Si je désactive sarka ils s’affichent bien, donc j’ai éliminé spip de mes réflexions. Je me demande quelle étape de configuration j’ai ratée, je précise que je n’avais pas fait de personnalisation sur l’affichage des logos.

Logo de _Laure_
mardi 13 mai 2014 à 15h12 - par  _Laure_

Ok, je viens de voir ça. Merci.

Logo de _Laure_
mardi 13 mai 2014 à 13h22 - par  _Eric_

J’ai retrouvé !

Suite à un bug sur l’affichage des vignettes qui n’étaient jamais réduites j’ai ajouté un paramètre de configuration qui permet de forcer la réduction à une valeur donnée. Par défaut c’est 0 qui devrait correspondre à "pas de réduction" et qui manifestement ne fonctionne pas ainsi.

Je viens de configurer ta page "modèles" avec la valeur 52 (qui est celle par défaut des vignettes de document) et c’est revenu comme avant.

Je vais vérifier de mon coté le petit souci qu’il y a dans le modèle quand même.

Logo de _Eric_
mardi 13 mai 2014 à 13h11 - par  _Eric_

Je ne pense pas que tu aies oublié quoi que ce soit. Y a pas de configuration sur ce point particulier, j’opterais plus pour un problème ou un choix pas forcément heureux dans le modèle.

Je regarde dès que possible.

Logo de _Eric_
mardi 13 mai 2014 à 11h54 - par  _Laure_

Je préfère afficher les docs joints dans le corps de l’article pour éviter qu’on me demande où se trouve le document. Il y a des gens qui oublient qu’on peut faire défiler une page... mais effectivement dans le portfolio le logo s’affiche.
Ceci dit c’est pas un bug gênant ! Tu ne penses pas que j’ai pu oublié de cocher quelque chose quelque part ?

Logo de _Laure_
mardi 13 mai 2014 à 10h37 - par  _Eric_

A priori non, d’après ce que je peux voir. Il faut que je regarde ça ce soir.

Une question tout de même : pourquoi ne pas utiliser le portfolio pour les fichiers joints de ce type ?

Logo de _Eric_
mardi 13 mai 2014 à 10h20 - par  _Eric_

Tu n’aurais pas un modèle doc ou img personnalisé ?

Logo de _Laure_
Passage de 3.2 stable à 3.3.46_resolu_
samedi 10 mai 2014 à 12h01 - par  _Laure_

Tout avait l’air de bien fonctionner sauf quand j’ai voulu sauvegarder la configuration de sarka :

Fatal error : Call to undefined function lister_pages_configuration() in ... /plugins/sarkaspip_33/formulaires/sauvegarde_cfg.php on line 6

Que dois-je faire docteur ?

Logo de _Laure_
jeudi 15 mai 2014 à 09h38 - par  Valin (Patrick)

Merci, j’ai fait la manip et en effet j’ai pu retrouver le site fonctionnel, j’ai supprimé le plugin COMMENTS qui se trouvait dans la liste.

Logo de Valin (Patrick)
mercredi 14 mai 2014 à 21h00 - par  _Eric_

Il y a surement une erreur mais tu l’as vois pas car tu n’as pas activé le niveau de debug SPIP nécessaire pour cela.

Pour contourner ce problème pour le moment :

  • renomme ton dossier plugins/ en plugins_old/
  • vide le cache de tmp/ à la main
  • et essaye de rentrer dans ton site.

Ensuite, remets uniquement zcore et sarka-spip et regarde si cela marche (a priori je dirais oui). Si oui, tu as un plugin incompatible surement : attention que le plugin Comments est totalement incompatible avec Sarka-SPIP par exemple.

Logo de _Eric_
mercredi 14 mai 2014 à 00h21 - par  Valin (Patrick)

suite à une mise à jour de mon sarka préféré, je me suis retrouvé avec.... une page blanche ! Meme pas une erreur, une page reellement blanche :

http://meteo.lycee-valin.fr

impossible d’acceder à l’espace privee pour faire quoique ce soit.

qui a deja vu ça ? Comment je peux me dépatouiller avec ce bug ?

Merci

Logo de Valin (Patrick)
lundi 12 mai 2014 à 18h27 - par  _Laure_

J’ai téléchargé la version 3.3.49 [82321] et tout semble bien se passer. J’ai supprimé sarkaspip_filtres de squelettes et configuré la page configuration typographique de sarka et ça marche.
Merci pour cette nouvelle fonctionnalité, très pratique quand on passe d’une version à l’autre pour ne pas oublier des fichiers de squelettes qu’on a bidouillé.
sarka reste un squelette pratique facilement configurable et qui ne cesse d’évoluer. Bravo.

Logo de _Laure_
dimanche 11 mai 2014 à 17h26 - par  _Eric_

Laure,

Voilà je viens de sortir la version 3.3.48. A partir de cette version, les couleurs peuvent être configurées comme tu veux à partir de la page nommée typographie.

Il faut absolument que tu supprimes ta personnalisation de ce filtre et que tu reportes juste les valeurs de couleur que tu as choisie dans la configuration. Tu devrais ainsi retrouver tes colorations de texte.

Dis-moi si ça marche.

Logo de _Eric_
samedi 10 mai 2014 à 17h07 - par  _Laure_

Je ne me rappelle plus depuis quelle version de sarka je n’arrivais plus à faire passer les couleurs personnalisables dans mes-options, et la seule solution que j’avais trouvée c’était de mettre mon sarkaspip_filtres dans squelettes.
Mais je n’ai pas réessayé avec mes-options depuis plusieurs versions et de toute façon pas avec 3.3.

Logo de _Laure_
samedi 10 mai 2014 à 16h33 - par  _Eric_

Ah oui, exact. Mais ce n’est pas comme ça qu’il aurait fallu surcharger cette fonction mais dans mes_options.php. Par contre, je pense que mon filtre n’est pas surchargeable tel que je l’ai codé.

Il faudrait que je revois cela soit en rendant soit en permettant juste de configurer les couleurs exactes car il me semble que c’est juste la valeur #xxxxx de chaque couleur que tu as modifiée non ?

Logo de _Eric_
samedi 10 mai 2014 à 14h45 - par  _Laure_

Les couleurs personnalisées.

Logo de _Laure_
samedi 10 mai 2014 à 14h15 - par  _Eric_

Oui absolument mais qu’as tu de perso dans ce fichier ? Ca me semble un peu suspect.

Logo de _Eric_
samedi 10 mai 2014 à 13h38 - par  _Laure_

J’ai trouvé. Il fallait que je modifie sarkaspip_filtres dans squelettes. Tout semble fonctionner.

Logo de _Laure_
samedi 10 mai 2014 à 12h15 - par  _Laure_

Je complète mon message. En fait l’erreur provient d’une personnalisation, si je comprends bien, car je viens de voir dans configuration des styles :

Fatal error : Cannot redeclare lister_fonds() (previously declared in .... squelettes/inc/sarkaspip_filtres.php:172) in ... plugins/sarkaspip_33/formulaires/inclure/cfg_couleurs_fonctions.php on line 24

Mais comment réparer je n’en ai aucune idée.

Logo de Jacques83300
Passage de 3.3.45 à 3.3.46
mardi 29 avril 2014 à 10h08 - par  Jacques83300

Bonjour,

Ce matin, après avoir mis à jour Sarkaspip de 3.3.45 à 3.3.46, j’obtiens le message suivant :
Fatal error : Cannot redeclare balise_BOUTONS_ADMIN_FORUM_dist() (previously declared in /home/www/37ed00d3b7b4d8da7c19d082a00db6f8/web/plugins/auto/comments/v3.3.0/comments_fonctions.php:57) in /home/www/37ed00d3b7b4d8da7c19d082a00db6f8/web/plugins/auto/sarkaspip/v3.3.46/public/sarkaspip_balises.php on line 278

Il semble donc qu’il y ait un conflit entre les plugins Sarkaspip et Comments. En effaçant le plugin Comments (par FTP) le site se remet à fonctionner.

Cordialement.

Logo de Jacques83300
jeudi 1er mai 2014 à 09h11 - par  Jacques83300

Bonjour Eric,

Merci pour ta réponse.
Effectivement, même s’il était installé et actif sur mon site, je n’utilisais plus le plugin Comments (non configuré). Je l’ai donc désinstallé complètement.

Néanmoins il est à signaler qu’il faut le désactiver avant d’installer la mise à jour de Sarkaspip sinon il faudra le supprimer manuellement pour rétablir le fonctionnement du site.

Cordialement.

Logo de Jacques83300
mardi 29 avril 2014 à 21h52 - par  _Eric_

Oui exact, je pourrais améliorer ça néanmoins le plugin comments ne sert à rien quand on utilise la version 3.3 de Sarka-SPIP ; c’est pour cela que j’ai pas hésité à redéclarer la fonction dans le squelette.

Donc il suffit de désactiver comments qui de toute façon te servira à rien.

Logo de Olivier
Activation plugin Sarka et ZCORE [2.0. ;[_resolu_
lundi 3 février 2014 à 15h05 - par  Olivier

Bonjour :)

Avec un SPIP 3.0.14 [21141] et Sarka-SPIP 3.3.38 - test (en installation via ftp)
j’ai un message à la tentation d’activation du plugin
" Le plugin Sarka-SPIP dépend de ZCORE [2.0. ;["
Quelqu’un a une piste ?
Merci :)

Logo de Olivier
mercredi 5 février 2014 à 11h24 - par  Olivier

Oki thks :)

Logo de Olivier
lundi 3 février 2014 à 20h44 - par  _Eric_

En fait la doc concerne la version 3.2. Elle n’est pas à jour pour la version 3.3. Néanmoins, il y a un article qui explique la migration 3.2 vers 3.3 : Migrer Sarka-SPIP de la branche 3.2 à 3.4 ou ultérieure

Logo de _Eric_
lundi 3 février 2014 à 20h40 - par  Olivier

Je propose donc une correction sur l’article 435
Remplacer

"En outre, Sarka-SPIP nécessite le plugin CFG pour fonctionner : installer le squelette c’est donc, a minima, installer les deux plugins, Sarka-SPIP et CFG."

par

En outre, Sarka-SPIP nécessite le plugin Z-core pour fonctionner : installer le squelette c’est donc, a minima, installer les deux plugins, Sarka-SPIP et Z-core".

Cdlt,

Logo de Olivier
lundi 3 février 2014 à 20h32 - par  Olivier

En effet :)
Merci infiniment JF35 !

Logo de Olivier
lundi 3 février 2014 à 18h21 - par  jf35

oui, il faut installer le plugin z-core

Logo de laurentlemar
Plantage lors du passage de la v 3.2.36 à la 3.3.34_resolu_
mardi 17 décembre 2013 à 11h09 - par  laurentlemar

Bonjour, j’ai tenté d’installer sur mon site sous sarka V 3.2.36 la version 3.3.34 et j’ai eu un magnifique plantage avec une disparition totale de ce qui était affiché sur ma page d’accueil. J’ai suivi le tutoriel mais je n’ai pas trouvé le dossier squelettes/ sur mon hébergeur et encore moins noisettes/bandeau.html noisettes/pied.html noisettes/navigation.html
noisettes/extra.html .
Je vous garantis que je les ai cherchés pourtant... ;-(
Je suis revenu à la version 3.2.36 et là miracle tout est réapparu.

Que puis-je faire Eric ? J’avoue que là cela dépasse mes compétences (je ne suis qu’un petit prof de Lettres qui bidouille...)
Voici l’adresse de mon site : michelet60b.clg.ac-amiens.fr

Laurent Lemarchand

Logo de laurentlemar
samedi 21 décembre 2013 à 15h47 - par  laurentlemar

Merci Eric !

Je me doutais bien que cela venait de certains plugins (et je pense surtout au couteau suisse !)
Il est vrai que je me suis laissé aller à tester toute une série de plugins et mon tort (la preuve en est) est de les avoir laissés actifs sans me soucier de leur véritable intérêt.
J’ai encore deux petites questions qui me turlupinent. Pourquoi y-a-t-il dans Sarka quand je vais sur le squelette des menus en gras sur lesquels je ne peux cliquer ?
2nde question : j’ai perdu mon thème d’habillage qui était dans zen garden. Quand je vais sur Zen Garden il n’y a plus que trois thèmes. Est-ce normal ?

Encore une fois mille mercis pour ton intervention et je promets d’être plus rigoureux quant à l’emploi des plugins.

Laurent Lemarchand

Logo de laurentlemar
samedi 21 décembre 2013 à 13h15 - par  _Eric_

Bon j’ai désactivé certains plugins et comme par hasard j’ai pu installer la nouvelle version de Sarka-SPIP 3.3.

Tu as des tonnes de plugins activés encore et je suis sur que pas la moitié sont utilisés. Ce n’est pas une bonne pratique. Il faut activer les plugins un par un en sachant si ils sont utiles et si non il faut les désactiver voire les supprimer carrément du ftp.

Logo de _Eric_
jeudi 19 décembre 2013 à 09h23 - par  laurentlemar

Merci pour ta réponse je t’ai envoyé par mail privé mes identifiants.

Laurent Lemarchand

Logo de laurentlemar
mardi 17 décembre 2013 à 12h05 - par  _Eric_

Déjà, la premier chose à savoir c’est que tu n’as aucun risque à essayer la version 3.3 du squelette car cela n’agit qu’au niveau de l’affichage et pas du contenu de ta base. Donc rien n’est perdu !

Il faudrait que je puisse avoir accès à ton site pour comprendre d’où vient le souci. En tout cas, si tu n’as pas de personnalisation dans squelettes/ c’est déjà un avantage. Ca devrait fonctionner rapidement.

Peux-tu m’envoyer ton login webmestre, ton ftp et son login et le lien vers ta base de données et son login. Tout cela par mail perso uniquement !

Logo de _Pétarel_
Site vide de contenu, mais pas vide de menu ni de bandeau, etc
mercredi 11 décembre 2013 à 20h49 - par  _Pétarel_

Bonjour,
Je fais partie des victimes de Mavenhosting qui a vu ses serveurs hackés en octobre et qui a perdu toutes les sauvegardes.
J’ai donc déménagé mon site principal que j’ai réinstallé avec une ancienne sauvegarde personnelle, mais je continue d’utiliser MH pour mon site de tests, puisque c’est payé et relativement sans gravité.

J’ai donc réinstallé petarel.net avec une bd qui contient rubriques, articles, documents.
Très bizarrement, le site a un "look" à peu près normal (à part un erreur d’affichage dans la colonne extra), mais aucun contenu.
http://www.petarel.net/
Réisntaller accès restreint au cas où ce serait ça ne change rien.
Je ne comprends vraiment pas ce qui se passe, cela fait plusieurs jours que je cherche, mais je ne vois pas. Quelqu’un aurait une idée pour m’orienter ?

Je me demande si ce ne serait pas encore un bug de Mavenhosting, parce que j’ai eu bien du mal à obtenir d’avoir une base de données fonctionnelle.

Merci !
Pétarel

Logo de _Pétarel_
jeudi 12 décembre 2013 à 15h23 - par  _Pétarel_

Ça y est, j’ai réussi en faisant une capture toutes les 100 ms, voici l’image. Personnellement, je ne vois pas du tout ce que ça peut vouloir dire, encore moins comment récupérer la chose.

Document joint :  message_erreur_seul.jpg
Logo de _Pétarel_
jeudi 12 décembre 2013 à 15h17 - par  _Pétarel_

C’est de la sorcellerie !
Maintenant, les articles s’affichent, mais plus tout ce qui s’affichait avant (bandeau, background, etc ) et en plus, je ne peux plus accéder aux pages privées, Le même message d’erreur que dans mon message précédent.

Je suis en train de chercher à voir le message d’erreur de quand je fais la sauvegarde.

Logo de _Pétarel_
jeudi 12 décembre 2013 à 14h57 - par  _Pétarel_

Merci Éric,
Effectivement tout est "affiché" normalement côté privé si je reste au niveau "rubriques", mais elles sont vides.
Je viens de tenter de restaurer la bd. Message d’erreur : vous êtes connecté sous le login xxxx mais celui-ci n’existe pas/plus dans la base. Essayez de vous reconnecter après avoir éventuellement redémarré votre navigateur.

Or le login avec lequel j’ai recréé Petarel.net est bien celui de l’auteur N°1 du site dont je récupère la base. Et c’est bien avec ce login que j’essaye de la réinstaller.

Je ne comprends rien Une idée ?
Quand je fais la sauvegarde de la base du site initial, il y a un message d’erreur (bandeau rouge) qui s’affiche, mais ça passe tellement vite (une mini fraction de seconde) que je n’arrive pas à voir de quoi il s’agit.

Logo de _Pétarel_
jeudi 12 décembre 2013 à 11h37 - par  _Eric_

A priori la noisette message est bien explicite : aucun article, aucun album. Dans l’espace privé as-tu bien tes articles ? Si oui, sont-ils bien publiés ?

Après il faudrait regarder dans la base de données.

Logo de chcausse
Affichage des images miniatures ne fonrtionne plus
samedi 16 novembre 2013 à 01h12 - par  chcausse

Avant tout, un grand merci pour ce squelette qui me permet de mettre en ligne des sites forts utiles.

Mais, après la dernière mise à jour de SPIP (SPIP 3.0.13 [20962]) et de Sarka-SPIP (Sarka-SPIP 3.3.33 [78513]), l’affichage des images au format miniature dans les articles ne se fait plus. Elles s’affichent au format effectif de l’image.

Je n’ai fait aucune modification sur les deux sites dont je m’occupe autre que les dernières mises à jour.

La fonction miniature automatique a-t-elle était supprimée, dans ces nouvelle versions ?

Pour exemple un article mise en ligne il y a deux mois

Cordialement

Christian

Logo de chcausse
jeudi 27 février 2014 à 14h07 - par  chcausse

Bonjour,

Non, actuellement, je n’ai plus de soucis. Seulement, pour arriver au même résultat qu’avant, j’ai du modifier ma configuration et mettre les images dans le portfolio. J’ai du passer (avec l’aide d’autres rédacteurs,) tous les articles pour passer les images dans le portfolio.

Mais actuellement, cela fonctionne normalement.

En tout cas, merci beaucoup pour ce plugin avec lequel je gère les deux sites dont je m’occupe.

Cordialement,

Christian Causse

http://genealogie-aveyron.fr/
http://paroisse-millau-grands-causses.org

Logo de chcausse
dimanche 23 février 2014 à 12h31 - par  _Eric_

Hello ChChausse,

As-tu toujours des soucis ou pas ? En regardant ton site il semble que ça fonctionne non ?

Logo de _Eric_
lundi 3 février 2014 à 23h01 - par  chcausse

Bonsoir,
Hélas, je n’ai pas trouvé de solution, nous avons, avec les autres rédacteurs, repassé toutes les pages du site.

Cordialement

Christian

Logo de chcausse
lundi 3 février 2014 à 12h29 - par  Franck_25

Bonjour,
J’ai rencontré le même problème :
les images s’affichent en taille réelle si elles ne sont pas dans le portfolio de l’article.
Quelle est la configuration requise pour régler le problème sans repasser sur toute les pages ?
Cordialement
Franck

Logo de Franck_25
vendredi 6 décembre 2013 à 09h43 - par  chcausse

Pour les images, je suis en mode non exclusif.

Logo de chcausse
vendredi 6 décembre 2013 à 09h35 - par  _Eric_

Quelle est ta configuration pour les modèles ?

Logo de _Eric_
vendredi 6 décembre 2013 à 09h33 - par  chcausse

Après de nombreuses heures de recherche, j’ai réussi à retrouver les miniatures pour mes sites.
Effectivement, actuellement pour que les images apparaissent en miniature, il faut qu’elles soient déposées dans le portefolio. ce qui modifie complètement le fonctionnement du site et devient génant pour un site ancien (plus de 700 articles en ligne et plus de 1100 images) où il est pratiquement impossible de modifier toutes les images.

Malgrè tout Merci encore pour ce plugin et tout le travail que vous partagez avec nous.

Cordialement

Christian

Logo de chcausse
samedi 30 novembre 2013 à 11h31 - par  _Eric_

Non, rien n’a été supprimé et surtout pas ça.
Par contre, il est possible que la configuration de la page Article ne soit pas bonne. Vérifier là.

Logo de hdeb
Squelette article.html avec la version 3.3
jeudi 24 octobre 2013 à 19h49 - par  hdeb

Bonjour,

Je passe de SARKA-Spip 3.2 à 3.3.

En 3.2, j’avais fait la personnalisation suivante : le clic sur un lien dans un article ouvrait une box dans laquelle s’affichait un autre article. Le squelette de ce dernier article (placé dans le dossier /squelettes) était une simple copie du fichier article.html de SARKA où la balise html body était affectée d’une class="article-fancy" définie dans le perso.css.html.

En 3.3, le squelette article du 3.2 est explosé en plusieurs parties, un fichier article.html compose "l’article" par un processus que je ne comprends pas. Le body est lui même en squelette.

Qu’est devenu le squelette article.html dans SARKA 3.3 ?

Logo de hdeb
jeudi 27 février 2014 à 14h51 - par  FK

J’ai mis en place un compromis avec :

  • l’appel aux scripts js dans inclure/head.html mais du coup il y a cet appel pour toutes les rubriques (ce qui est inutile, on doit pouvoir personnaliser le head pour certaines rubriques .... ou pas ?)
  • le menu identique pour tous les articles (alors qu’une partie de ce menu ne sert que pour certaines rubriques, là aussi je pense qu’il y a une solution )

Si vous avez une idée pour la version 3.3 merci de me donner quelques pistes.

Logo de FK
mercredi 26 février 2014 à 15h29 - par  FK

Re-bonjour, est-ce que le <head> est dans le fichier structure.html de z-core ?

( comme dit par ici ) sinon y a t-il un plugin configurateur compatible tel que ciparam ? je cherche, je cherche mais je voudrai éviter de tourner en rond ...

Logo de FK
mardi 25 février 2014 à 12h56 - par  FK

Merci, effectivement avec content/article=553.html on modifie le corps et c’est OK, mais justement dans body=553.html je pouvais aussi modifier le header ...

En fait dans les articles de cette rubrique je souhaite appelé un <header> perso pour un menu de navigation différent et une autre feuille de styles + scripts js.

Je cheche donc un appel à un <head></head> personnalisé pour les articles cette rubrique ... ??

Logo de FK
mardi 25 février 2014 à 12h29 - par  _Eric_

Salut FK,

Non il ne faut pas créer un nouveau body.
Tu as juste à créer un article=553.html dans le dossier content/ et d’y mettre ta personnalisation en utilisant celui par défaut. Attention, ce fichier ne contient que le corps de la page et pas le bandeau ni le pied de page ni le header.

Commence déjà par ça et dis moi.

Logo de _Eric_
mardi 25 février 2014 à 11h15 - par  FK

Bonjour, je me lance dans cette migration vers Sarka 3.3 ....

L’essentiel c’est bien passé puis j’ai réussi à refaire quelques personnalisations et je bloque sur ce qui suit :

- avant pour des articles de certaines rubriques on pouvait faire un fichier article=553.html en référence à la rubrique numérotée 553

- maintenant j’ai réussi certaines modifs avec body=553.html

Par contre c’est uniquement pour la partie <body></body> et j’avais un css différent appelé dans le <head></head> mais dans cette nouvelle formule Z je ne trouve pas dans quel fichier est écrit <head> ce qui me permettrait peut-être de faire ma modif ... par exemple dans inclure/head.html il n’y a pas la balise <head>

une idée ?

Logo de FK
lundi 11 novembre 2013 à 17h36 - par  preuilloux

bonjour, je voudrais masquer le bouton "sites favoris" et la noisette "recherche" comme je le faisais dans les anciennes version de sarka. En modifiant les squelettes mais je n’y arrive pas. Ni au niveau du fichier dist.html du dossier aside ni au niveau du fichier inc_menu_pages_speciales.html
merci de votre aide

Logo de preuilloux
samedi 2 novembre 2013 à 15h40 - par  preuilloux

Suite à mon message j’ai voulu modifier mon e-mail enregistré dans sarka sans succès, vos réponses ne me parvenant pas merci de prendre note si possible du nouveau :
info@preuillysurclaise.fr

Logo de preuilloux
samedi 2 novembre 2013 à 15h29 - par  preuilloux

Bonjour, je viens d’installer sarka 3.3 en local afin d’apporter les corrections sur les personnalisations existantes avant de mettre en ligne. Tout s’est bien passé en suivant vos conseils de créer un nouveau dossier squelettes j’ai pu grace à la nouvelle version de composition retrouver mes pages spéciales rapidement Mais ... il y a un mais j’ai brutalement eu un bug avec le squelette BODY quand je passe en ligne j’ai un message d’erreur me disant qu’il ne trouve pas les squelettes "aside" "extra" "footer" et "header" de sarka. Plein de courage j’ai tenter d’installer la 4 sans plus de succès. Merci de votre aide car je suis un peu perdu.

Logo de preuilloux
samedi 26 octobre 2013 à 23h36 - par  hdeb

Merci _Eric_ .
Je viens de lire la doc sur Z-Core et le principe du framework.
J’ai hâte de lire cet article !

Logo de hdeb
vendredi 25 octobre 2013 à 20h53 - par  _Eric_

Désolé, comme je l’ai dit sur d’autres fils je vais faire un article sur la migration vers la version 3.3.

Logo de _Eric_
vendredi 25 octobre 2013 à 19h47 - par  hdeb

Réflexion faite, je repars à zéro avec SARKA 3.3.
Un bon nettoyage ne fera pas de mal.
Difficile sans documentation.
Cdt

Ps. Mes excuses pour l’absence de titre à ce sujet ...

Logo de FaceNux
MAJ de Sarka (STABLE), comment procède t-on ?_resolu_
dimanche 22 septembre 2013 à 18h53 - par  FaceNux

Bonsoir,

Encore une question qui me perturbe énergiquement après le parcours sur le site ou je ne trouve pas ma réponse, car j’ai sans aucuns doute loupé le coche !

MErci.

Logo de FaceNux
lundi 14 octobre 2013 à 19h40 - par  Valin (Patrick)

Merci Eric. Tout fonctionne. Et loin (voire très loin...) de moi l’idée de penser que vous puissiez mettre en ligne des versions inutilisables.
Il faut juste penser aux "simples" utilisateurs comme moi qui ne sont pas des experts et donc ont besoin de gens comme toi pour répondre à des questions, certes naïves et superflues pour des experts comme toi, mais d’une extrême importance pour des "apprentis" comme moi...
Je compte sur les membres de la TEAM pour nous guider lors d’un passage programmé à la branche 4 de cet outil précieux qu’est SARKA

Logo de Valin (Patrick)
lundi 14 octobre 2013 à 09h14 - par  _Eric_

Patrick,

Il n’y a pas de rapport entre passer d’une version 3.2.x à 3.2.32 et passer d’une version 3.2 à une version 4.0 qui repense totalement le squelette ainsi que sa configuration.

Donc en faisant ce pas tu as détruit toute ta configuration ce qui t’a amené les déboires dont tu parles sachant que de toute façon ce n’est jamais irréversible vu que la base de données est conservée intacte.

Donc non, tu n’as pas d’angoisse à faire la mise à jour vers 3.2.32 comme d’habitude et je crois pas me rappeler que nous ayons déjà sorti des versions inutilisables pour le plaisir :p.

Logo de _Eric_
jeudi 10 octobre 2013 à 19h28 - par  Valin (Patrick)

Bonsoir à vous tous. J’ai, après quelques déboires, réussi à remettre mon site d’aplomb. J4ai un autre site que je prefererai ne pas voir tomber en carafe ( http://lycee-valin.fr ) une mise à jour de SARKA 3.2.32 est proposée, puis-je la faire sans risquer le meme souci ?
merci

Logo de Valin (Patrick)
jeudi 3 octobre 2013 à 13h35 - par  _Eric_

Pour info, nous avons changé temporairement le préfixe de la version 4 du squelette ce qui fait que cette version ne sera plus considérée comme une mise à jour de la version 3.

Par contre, il reste que la version 3.3 est toujours proposée en upgrade de la 3.2, ce qui n’est pas grave car elles sont compatibles à quelques personnalisations près. Si vous avez des personnalisations de fichier html avec la 3.2 il se peut que le passage à la 3.3 perturbe ces personnalisations. Mais il est très facile d’adapter ces personnalisations pour le 3.3.
Je ferai un billet à ce propos bientôt.

Logo de _Eric_
mardi 1er octobre 2013 à 19h52 - par  patrickm

@ jacques83300
Merci Jacques !
Cordialement

Logo de patrickm
lundi 30 septembre 2013 à 09h22 - par  _Eric_

Oui, je suis désolé nous sommes dans une situation délicate quant aux mises à jour. L’outil SVP ne gère pas les branches intermédiaires et cela pose un réel problème quand on a deux branches en cours.

Pour l’instant, il faut faire manuellement les mises à jour de Sarka-SPIP, à l’ancienne avec le FTP, en prenant le zip sur ce site ou sur le site de Plugins SPIP à la page http://plugins.spip.net/sarkaspip.html.

Je vais voir comment je peux résoudre ce souci.

Logo de _Eric_
dimanche 29 septembre 2013 à 23h24 - par  Jacques83300

Bonjour Patrick,

Il te suffit de désinstaller la version 4.3.3 et tu devrais pouvoir activer la 3.3.24 que tu auras téléchargée du site Sarka-Spip.

Cordialement.

Logo de Jacques83300
dimanche 29 septembre 2013 à 14h42 - par  patrickm

Bonjour
Même problème avec la maj 4.3.3, impossible de revenir à la version antérieure, déclarée obsolète...
Cordialement

Logo de patrickm
samedi 28 septembre 2013 à 11h56 - par  Jacques83300

Bonjour,

Comme d’autres, j’ai laissé faire la mise à jour automatique des plugins et je me suis retrouvé avec la version non stable 4.3.3 de Sarka-Spip.
J’ai donc réinstallé la 3.3.24 à partir du lien sur le site et j’ai perdu toutes les données de configuration antérieures.

Vu que la version 4 n’est pas stable, n’est-il pas possible d’empêcher qu’elle soit utilisée comme version de mise à jour automatique du plugin ?

Des mises à jour de la version 3.3 sont-elles encore prévues ? Si oui, comme en être averti vu que ce qui est proposé par la mise à jour du plugin est une version 4.x ?

Merci pour vos réponse et encore une fois bravo pour le travail accompli.

Cordialement.

Logo de Jacques83300
mardi 24 septembre 2013 à 22h07 - par  Valin (Patrick)

En fait pour une histoire de cache cela ne s’affichait pas par contre plus aucune configuration et mise en page de la version 3.2 tout est à ré faire..... C’est normal ?

Logo de Valin (Patrick)
mardi 24 septembre 2013 à 16h50 - par  Valin (Patrick)

Bonjour, en faisant les mises à jours de mes plugins je n’ai pas fait attention et notre SARKA préféré a installé la mise à jour 4. Plantage de mon site http://meteo.lycee-valin.fr
J’ai supprimé le plugin par FTP et j’ai remis la version stable 3.3 mais la le site reste en SPIP sans habillage avec SARKA pourtant il est bien activé.....
Que faire ?

Logo de Valin (Patrick)
lundi 23 septembre 2013 à 11h54 - par  FaceNux

En faisant un test sur un de mes sous-domaine de prod ca fonctionne très bien, je dois avoir un probleme de droits sur le repertoire de mon local .

Logo de FaceNux
dimanche 22 septembre 2013 à 20h28 - par  _Eric_

Ah ben je vois pas pourquoi tu n’as rien. Sans voir le site je ne peux pas grand chose d’autre.

Logo de _Eric_
dimanche 22 septembre 2013 à 20h21 - par  FaceNux

En local :
/plugins/auto

Logo de FaceNux
dimanche 22 septembre 2013 à 20h17 - par  _Eric_

Hum, c’est bien étrange. Tu l’as installé dans quel répertoire de ton site ?

Logo de _Eric_
dimanche 22 septembre 2013 à 20h15 - par  FaceNux

Mais c’est mon problème, il n’apparaît pas dans les inactifs !!! et la 3.2.32 est déjà désactivée.

Logo de FaceNux
dimanche 22 septembre 2013 à 20h09 - par  _Eric_

Ben c’est dans les plugins inactifs. Mais il faut que tu désactives le plugin Sarka-SPIP d’abord et tu actives le nouveau zip que tu as installé. Ensuite tu peux virer l’ancienne version du squelette de ton ftp.

Logo de _Eric_
dimanche 22 septembre 2013 à 19h56 - par  FaceNux

C’est bien ce que je fais...mais après il ne me propose rien ! comment je lui dit de prendre cette archive ?

Logo de FaceNux
dimanche 22 septembre 2013 à 19h05 - par  _Eric_

Oui c’est un souci, tu ne peux pas le faire avec le chargeur auto de SPIP. Dans ce cas, il faut utiliser la méthode manuelle par FTP en utilisant le zip que tu peux télécharger sur ce site dans la noisette Téléchargements, le lien nommé « Sarka-SPIP 3.2 pour SPIP 3 ».

Logo de _Eric_
dimanche 22 septembre 2013 à 18h59 - par  FaceNux

Bonsoir,
Je cherche juste à migré ma version sarka de 3.2.32 vers 3.2.34 :(

Logo de FaceNux
dimanche 22 septembre 2013 à 18h55 - par  _Eric_

Je ne vois pas de quoi tu parles. Peux-tu expliquer quel est le souci ou quel est ton besoin ?

Logo de Philippe
Page "Contact" affiche "Erreur 404" après mise à jour vers Sarka-SPIP 3.2.33_resolu_
dimanche 22 septembre 2013 à 10h21 - par  Philippe

Bonjour,

J’ai fait la mise à jour du plugin Sarka-SPIP 3.2.32 vers 3.2.33 sur mon site et je signale que la page contact.html ne s’affiche plus : elle affiche "Erreur 404".
Je précise que je ne n’utilise pas le plugin "Accès restreint.
En revenant à 3.2.32, le problème disparait.
Apparemment le problème provient du nouveau fichier contact.hrml de Sarka-SPIP 3.2.33.

Logo de Philippe
dimanche 22 septembre 2013 à 14h21 - par  Philippe

Nickel : cela fonctionne bien en 3.2.34.
Merci Eric.

Logo de Philippe
dimanche 22 septembre 2013 à 11h27 - par  _Eric_

Oui, merci j’ai introduit un bug avec la modification de la 401.

Le zip de la version 3.2.34 sera disponible dans une petite heure.

Logo de tlambillard
problème nouveau avec Agenda
mardi 17 septembre 2013 à 17h54 - par  tlambillard

Bonjour
je gère plusieurs sites avec Spip et Sarka ( SPIP 3.0.11 [20757] | Sarka-SPIP 3.2.29)
et depuis quelques jours j’ai de gros problèmes sur les agendas.
sur le site chartreshandisport28.fr l’agenda ne me propose plus les mois à venir ni les années 2014 et autres...
cela vient d’où ?
Merci de votre aide
Thierry

Logo de tlambillard
dimanche 22 septembre 2013 à 11h45 - par  _Eric_

SVP, ce fil est dédié à un problème sur l’Agenda. Pour parler des mises à jour du squelette veuillez ouvrir un autre fil sinon on ne sait plus qui répond à quoi.

Néanmoins, je viens de tester l’ajout d’un évènement pendant le mois d’octobre et j’ai bien vu apparaitre les flèches pour m’y déplacer.

Pour ceux qui ont ce souci :

  • pourrais-je avoir l’url du site ?
  • la liste des plugins utilisés,
  • et ce qui serait bien c’est que je puisse m’y connecter en webmestre (login à fournir via mon mail privé).

Merci d’avance.

Logo de _Eric_
dimanche 22 septembre 2013 à 04h55 - par  Denis

Bonjour,

J’ai eu le même problème que Flocar. La raison est je pense que sarka 3.2.32 est connue comme une version ’test’ alors que sarka 3.2.33 est une version ’stable’. Lors de la mise à jour Spip essaie donc de mettre à jour vers la nouvelle version test qui est la version 4.3.2 et cela ne marche pas. Solution : d’abord désactiver sarka 3.2.32 puis aller dans ’ajouter des plugins’ et ’télécharger et activer’ la dernière version stable de sarka : la 3.2.33. Ensuite aller dans ’plugins inactifs’ pour supprimer la version obsolète de sarka 3.2.32.

Cordialement,

Denis

Logo de Denis
samedi 21 septembre 2013 à 20h19 - par  _Eric_

Oui je viens de m’en apercevoir. Il faut que je regarde.

Par contre pour Flocar, il ne faut pas encore utiliser cette nouvelle version 4 du squelette car je ne la supporte pas encore. Prends la 3.3

Logo de _Eric_
samedi 21 septembre 2013 à 18h45 - par  laurentlemar

Bonjour j’ai le même problème sur mon site spip 3.0.11 et sarka 3.2.32.

Cordialement

Laurent

Logo de laurentlemar
mercredi 18 septembre 2013 à 17h08 - par  Flocar

Bonjour,

Monsite tourne sous SPIP 3.0.11 et sarka 3.2.32 une mise à jour de sarka est proposée.
A la validation de demande de mise à jour, j’ai ce message :
Le plugin Sarka-SPIP dépend de BOOTSTRAP [1.3. ;].
Pouvez vous m’indiquer ce qu’il faut faire pour faire la mise à jour ?
Cordialement,
Michel

Logo de Valin (Patrick)
Nouveau sujet - donnez un titre explicite !_resolu_
dimanche 4 août 2013 à 16h21 - par  Valin (Patrick)

Bonjour, je profite de cette période du mois d’aout pour faire du e-menage....
cela concerne le site http://lycee-valin.fr
il est SPIP 2.1.10 [17657] | Sarka-SPIP 3.0.8 [54368].
je compte faire une migration.
Quelle est la manip à réaliser sachant que ce site fonctionne depuis qq années et je ne voudrais pas perdre son contenu..
j’ai fait une sauvegarde de la base de données.
J’ai installé un SPIP tout neuf dernière version dans un dossier nommé BETA sur l’herbergeur, j’ai copié le dernier SAKRA dans le dossier plugins/auto/
J’ai créé un sous domaine beta.lycee-valin.fr qui pointe vers ce nouveau SPIP. Pour ne pas toucher à la version actuelle du site.
Je pensais une fois le nouveau installé faire pointer vers le nouveau site.

Qui peut m’aider à faire cette migration majeure sans encombre ?

Merci Patrick

Logo de Valin (Patrick)
dimanche 22 septembre 2013 à 11h29 - par  _Eric_

Bon Patrick,

Tout semble s’être bien passé d’après ce que je vois de ton site. Super, je clos le fil donc.

Logo de jojo
Fonctionnement du plugin rainette_resolu_
vendredi 26 juillet 2013 à 11h28 - par  jojo

Bonjour
J’ai migré un site de test sous SPIP 3.0.10 [20600] et sarka-SPIP 3.2.31 [74270]
J’ai le plugin rainette_v1(compatible version 3)
Paramètre FRXX0290.
Apparemment cela ne fonctionne pas ?
Merci
http://devgeorges.free.fr

Logo de jojo
samedi 3 août 2013 à 09h31 - par  jojo

Bonjour
OK et merci
Je réfléchis pour quitter Free
Bonnes vacances

Logo de jojo
lundi 29 juillet 2013 à 20h58 - par  AJCF RV

c’est normal, c’est Free. Avant la rainette fonctionnait bien, puis restrictions, elle ne fonctionne plus.
Pleins de choses fonctionnaient avec Free, puis de moins en moins, mais bon, c’est gratuit ...

J’avais déjà répondu à une question sur le forum à ce sujet.

Logo de AJCF RV
lundi 29 juillet 2013 à 13h41 - par  _Eric_

Humm,

D’après ce que je vois, ça fonctionne mais les données météo ne sont pas retournées par le service weather. Essaye avec Paris par exemple et ça devrait fonctionner.

Si c’est bien ça, alors il faudrait essayer la nouvelle version de Rainette qui permet de choisir son service météo. Le souci c’est que je n’ai pas encore produit le zip car elle était en développement. Donc en attendant peux-tu essayer de choisir une ville proche qui fonctionne ?

Logo de salon des dames
Nouveau sujet - accès à l’espace privé
vendredi 21 juin 2013 à 11h40 - par  salon des dames

Je ne peux plus accéder à l’espace privé. "Connexion" a disparu de la page d’accueil .

Logo de salon des dames
dimanche 23 juin 2013 à 11h17 - par  salon des dames

merci pour ce dépannage rapide, tout est ok

Logo de salon des dames
vendredi 21 juin 2013 à 14h32 - par  Suske

En principe l’espace privé se trouve sous http://site.tld/ecrire (http://salondesdames.fr/ecrire ?)

Après y avoir accédé, vérifiez la configuration du menu ?

Logo de josiane
compatibilité avec spip 3.0.8 ?_resolu_
vendredi 26 avril 2013 à 14h02 - par  josiane

je viens d’installer un spip tout neuf, 3.0.8.
quand je veux installer le pluging sarka-spip en mode "auto", il n’apparaît pas dans la liste des plugins dispo.

J’ai forcé la chose en donnant le lien direct dans la fenêtre de chargement des plugins.

Et là spip me dit clairement qu’il n’active pas ce plugin parce qu’il n’est pas compatible...

Que puis-je faire pour remédier à tout ça ?

merci !

Logo de josiane
mercredi 1er mai 2013 à 11h46 - par  _Eric_

Bonjour,

Il faut passer le choix état du plugin à "tous les états" car par défaut la recherche utilise l’état stable. Je te conseille de refaire cela ainsi car ensuite tu pourras utiliser le chargeur automatique pour faire les mises à jour.

Logo de _Eric_
dimanche 28 avril 2013 à 08h53 - par  josiane

probable fin d’alerte :
après avoir chargé à la main la dernière version 3.2.28, il y a compatibilité.

je vais pouvoir tester si tout fonctionne bien.

encore merci pour ce joli sarka qui rend bien des services !